summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libtool/libtool_2.4.6.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-30 13:09:29 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-31 22:47:35 +0100
commite3497cc22b969e02efa54e4e54e087dbb91d8ced (patch)
tree1f2650fa281ac2469b12bd02eb2b404be96c22d7 /meta/recipes-devtools/libtool/libtool_2.4.6.bb
parent9c419271b5cf927924682c3200451979f02409bb (diff)
downloadpoky-e3497cc22b969e02efa54e4e54e087dbb91d8ced.tar.gz
multilib_script: Add support for multilib scripts
Whilst the package managers handle multilib ELF binaries well, they don't handle scripts in the *bindir directories well. This adds support for marking these up so that they can be handled using update-alternatives. Its done this way so that non-multilib systems don't see any changes and there is standardisation amongst the multilibs on how the alternatives are named and prioritiesd. The priotitisation code needs to be added but this change means there is somewhere to add it. Recipe needs to set MULTILIB_SCRIPTS in the form <pkgname>:<scriptname>, e.g. MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/file1 ${PN}:${base_bindir}/file2" to indicate which script files to process from which packages. libtool is used a as a reference to stop the libtool scripts conflicting in a multilib case and allows the kernel-devsrc change to be merged. (From OE-Core rev: 18e837433d07cfdce4019c13f682c6676425a2ad) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/libtool/libtool_2.4.6.bb')
-rw-r--r--meta/recipes-devtools/libtool/libtool_2.4.6.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/libtool_2.4.6.bb b/meta/recipes-devtools/libtool/libtool_2.4.6.bb
index b02620b4b4..b8a5240885 100644
--- a/meta/recipes-devtools/libtool/libtool_2.4.6.bb
+++ b/meta/recipes-devtools/libtool/libtool_2.4.6.bb
@@ -26,3 +26,7 @@ do_install_append () {
26 -e "s@${HOSTTOOLS_DIR}/@@g" \ 26 -e "s@${HOSTTOOLS_DIR}/@@g" \
27 -i ${D}${bindir}/libtool 27 -i ${D}${bindir}/libtool
28} 28}
29
30inherit multilib_script
31
32MULTILIB_SCRIPTS = "${PN}:${bindir}/libtool"