summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/librepo/librepo_git.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-03-10 13:23:50 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-11 16:09:14 +0000
commita2b6910d14b90a137c6e265cf081c6ee38832e2e (patch)
tree6bbb87a6bb5887db0a93f67fa4401e971af9a8f7 /meta/recipes-devtools/librepo/librepo_git.bb
parent5892bb7577b8c146d00551ff5dfde146c65e1a76 (diff)
downloadpoky-a2b6910d14b90a137c6e265cf081c6ee38832e2e.tar.gz
librepo: add a recipe
librepo is needed by dnf and libdnf. (From OE-Core rev: 64dd708d14f8eadb25c3b590bfdc894e2cbb246e) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/librepo/librepo_git.bb')
-rw-r--r--meta/recipes-devtools/librepo/librepo_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/librepo/librepo_git.bb b/meta/recipes-devtools/librepo/librepo_git.bb
new file mode 100644
index 0000000000..70e88c47b9
--- /dev/null
+++ b/meta/recipes-devtools/librepo/librepo_git.bb
@@ -0,0 +1,24 @@
1SUMMARY = " A library providing C and Python (libcURL like) API for downloading linux repository metadata and packages."
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
4
5SRC_URI = "git://github.com/rpm-software-management/librepo.git \
6 file://0001-Correctly-set-the-library-installation-directory.patch \
7 file://0002-Do-not-try-to-obtain-PYTHON_INSTALL_DIR-by-running-p.patch \
8 file://0003-tests-fix-a-race-when-deleting-temporary-directories.patch \
9 file://0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch \
10 "
11
12PV = "1.7.20+git${SRCPV}"
13SRCREV = "e1137cbbda78fecb192146300790680a5bc811b1"
14
15S = "${WORKDIR}/git"
16
17DEPENDS = "curl expat glib-2.0 openssl attr libcheck gpgme"
18
19inherit cmake distutils-base pkgconfig
20
21EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR}"
22
23BBCLASSEXTEND = "native"
24