summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/json-c/json-c_0.11.bb
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2014-06-26 14:36:22 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2014-06-26 15:32:53 +0200
commitf4cf9fe05bb3f32fabea4e54dd92d368967a80da (patch)
tree487180fa9866985ea7b28e625651765d86f515c3 /meta/recipes-devtools/json-c/json-c_0.11.bb
downloadpoky-f4cf9fe05bb3f32fabea4e54dd92d368967a80da.tar.gz
initial commit for Enea Linux 4.0
Migrated from the internal git server on the daisy-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'meta/recipes-devtools/json-c/json-c_0.11.bb')
-rw-r--r--meta/recipes-devtools/json-c/json-c_0.11.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/json-c/json-c_0.11.bb b/meta/recipes-devtools/json-c/json-c_0.11.bb
new file mode 100644
index 0000000000..389e0f9ebf
--- /dev/null
+++ b/meta/recipes-devtools/json-c/json-c_0.11.bb
@@ -0,0 +1,21 @@
1SUMMARY = "C bindings for apps which will manipulate JSON data"
2DESCRIPTION = "JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C."
3HOMEPAGE = "https://github.com/json-c/json-c/wiki"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2"
6
7SRC_URI = "https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz"
8
9SRC_URI[md5sum] = "aa02367d2f7a830bf1e3376f77881e98"
10SRC_URI[sha256sum] = "28dfc65145dc0d4df1dfe7701ac173c4e5f9347176c8983edbfac9149494448c"
11
12RPROVIDES_${PN} = "libjson"
13
14PARALLEL_MAKE = ""
15
16inherit autotools
17
18do_configure_prepend() {
19 # Clean up autoconf cruft that should not be in the tarball
20 rm -f ${S}/config.status
21}