summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/jquery/jquery_3.5.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-05-31 17:52:40 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-04 13:27:31 +0100
commit6c6bf5ef9b1f16d0d4a40a62de58f486a48686f7 (patch)
tree0e7b77842452c9793da01ea35d6a498e3d1ac1be /meta/recipes-devtools/jquery/jquery_3.5.1.bb
parent5f9bdc5972905634db0362dc8c469577ef4d44f6 (diff)
downloadpoky-6c6bf5ef9b1f16d0d4a40a62de58f486a48686f7.tar.gz
jquery: update to 3.5.1
(From OE-Core rev: d1842007c56cfcac67e8c7fb91638a411b8f27f5) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/jquery/jquery_3.5.1.bb')
-rw-r--r--meta/recipes-devtools/jquery/jquery_3.5.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/jquery/jquery_3.5.1.bb b/meta/recipes-devtools/jquery/jquery_3.5.1.bb
new file mode 100644
index 0000000000..b4d7e80afe
--- /dev/null
+++ b/meta/recipes-devtools/jquery/jquery_3.5.1.bb
@@ -0,0 +1,31 @@
1SUMMARY = "jQuery is a fast, small, and feature-rich JavaScript library"
2HOMEPAGE = "https://jquery.com/"
3LICENSE = "MIT"
4SECTION = "devel"
5LIC_FILES_CHKSUM = "file://${WORKDIR}/${BP}.js;beginline=8;endline=10;md5=ebd7bc5d23ab165188e526a0c65d24bb"
6
7SRC_URI = "\
8 https://code.jquery.com/${BP}.js;name=js \
9 https://code.jquery.com/${BP}.min.js;name=min \
10 https://code.jquery.com/${BP}.min.map;name=map \
11 "
12
13SRC_URI[js.sha256sum] = "416a3b2c3bf16d64f6b5b6d0f7b079df2267614dd6847fc2f3271b4409233c37"
14SRC_URI[min.sha256sum] = "f7f6a5894f1d19ddad6fa392b2ece2c5e578cbf7da4ea805b6885eb6985b6e3d"
15SRC_URI[map.sha256sum] = "511d6f6d3e7acec78cd2505f04282b6e01329b4c24931f39d91739d0d1ddeef8"
16
17UPSTREAM_CHECK_REGEX = "jquery-(?P<pver>\d+(\.\d+)+)\.js"
18
19inherit allarch
20
21do_install() {
22 install -d ${D}${datadir}/javascript/${BPN}/
23 install -m 644 ${WORKDIR}/${BP}.js ${D}${datadir}/javascript/${BPN}/${BPN}.js
24 install -m 644 ${WORKDIR}/${BP}.min.js ${D}${datadir}/javascript/${BPN}/${BPN}.min.js
25 install -m 644 ${WORKDIR}/${BP}.min.map ${D}${datadir}/javascript/${BPN}/${BPN}.min.map
26}
27
28PACKAGES = "${PN}"
29FILES_${PN} = "${datadir}"
30
31BBCLASSEXTEND += "native nativesdk"