summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/i2c-tools/i2c-tools_3.1.1.bb
diff options
context:
space:
mode:
authorRandy MacLeod <Randy.MacLeod@windriver.com>2015-07-08 19:36:28 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-07-12 22:55:42 +0100
commit4a32362c0d9af6208dbb318b74585eac4b336f0a (patch)
treeb9c3f3c6be6967f6d99f508f92793187e18c4a0d /meta/recipes-devtools/i2c-tools/i2c-tools_3.1.1.bb
parent1bd4ee1d0312816fd62fac8343f9f794bab5ddff (diff)
downloadpoky-4a32362c0d9af6208dbb318b74585eac4b336f0a.tar.gz
i2c-tools: uprev to 3.1.2
The only changes based on the CHANGES file are: decode-dimms: Fix DDR3 extended temp range refresh rate decoding py-smbus: Add support for python 3 The python3 changes use python3 as the default and 2 as the fallback. py-smbus is not currently built so no python changes have been made. The local copy of Module.mk is unchanged aside from moving it to a directory that is not version specific to avoid uprev noise. (From OE-Core rev: e0cbd3c64dab5db5df6415bbc0042b1b50b3c7ac) Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/i2c-tools/i2c-tools_3.1.1.bb')
-rw-r--r--meta/recipes-devtools/i2c-tools/i2c-tools_3.1.1.bb34
1 files changed, 0 insertions, 34 deletions
diff --git a/meta/recipes-devtools/i2c-tools/i2c-tools_3.1.1.bb b/meta/recipes-devtools/i2c-tools/i2c-tools_3.1.1.bb
deleted file mode 100644
index 71c98a4fd1..0000000000
--- a/meta/recipes-devtools/i2c-tools/i2c-tools_3.1.1.bb
+++ /dev/null
@@ -1,34 +0,0 @@
1SUMMARY = "Set of i2c tools for linux"
2SECTION = "base"
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
5
6SRC_URI = "http://dl.lm-sensors.org/i2c-tools/releases/${BP}.tar.bz2 \
7 file://Module.mk \
8"
9SRC_URI[md5sum] = "0fdbff53ebd0b8d9249256d6c56480b1"
10SRC_URI[sha256sum] = "14d4d7d60d1c12e43f2befe239c682a5c44c27682f153d4b58c1e392d2db1700"
11
12inherit autotools-brokensep
13
14do_compile_prepend() {
15 cp ${WORKDIR}/Module.mk ${S}/eepromer/
16 sed -i 's#/usr/local#/usr#' ${S}/Makefile
17 echo "include eepromer/Module.mk" >> ${S}/Makefile
18}
19
20do_install_append() {
21 install -d ${D}${includedir}/linux
22 install -m 0644 include/linux/i2c-dev.h ${D}${includedir}/linux/i2c-dev-user.h
23 rm -f ${D}${includedir}/linux/i2c-dev.h
24}
25
26PACKAGES =+ "${PN}-misc"
27FILES_${PN}-misc = "${sbindir}/i2c-stub-from-dump \
28 ${bindir}/ddcmon \
29 ${bindir}/decode-edid \
30 ${bindir}/decode-dimms \
31 ${bindir}/decode-vaio \
32 "
33RDEPENDS_${PN} += "${PN}-misc"
34RDEPENDS_${PN}-misc += "perl"