summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/guile/guile_2.0.6.bb
diff options
context:
space:
mode:
authorMarko Lindqvist <cazfi74@gmail.com>2012-12-14 13:43:36 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-19 17:54:53 +0000
commit606561953a5fafa735ffe34311dc490f6ee9c554 (patch)
treeb19f965c8192d01b3794d3967130869167a9e5f9 /meta/recipes-devtools/guile/guile_2.0.6.bb
parent00dd34b92f58295979957a38e827eafb41df8372 (diff)
downloadpoky-606561953a5fafa735ffe34311dc490f6ee9c554.tar.gz
guile: update to upstream version 2.0.7
change-install-data-hook-to-install-exec-hook-in-gui.patch is now part of upstream. (From OE-Core rev: 3d03eb7430849d7bd709e70a300efeb4a88cdb20) Signed-off-by: Marko Lindqvist <cazfi74@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/guile/guile_2.0.6.bb')
-rw-r--r--meta/recipes-devtools/guile/guile_2.0.6.bb103
1 files changed, 0 insertions, 103 deletions
diff --git a/meta/recipes-devtools/guile/guile_2.0.6.bb b/meta/recipes-devtools/guile/guile_2.0.6.bb
deleted file mode 100644
index 45603e6eda..0000000000
--- a/meta/recipes-devtools/guile/guile_2.0.6.bb
+++ /dev/null
@@ -1,103 +0,0 @@
1SUMMARY = "Guile is the GNU Ubiquitous Intelligent Language for Extensions."
2DESCRIPTION = "Guile is the GNU Ubiquitous Intelligent Language for Extensions,\
3 the official extension language for the GNU operating system.\
4 Guile is a library designed to help programmers create flexible applications.\
5 Using Guile in an application allows the application's functionality to be\
6 extended by users or other programmers with plug-ins, modules, or scripts.\
7 Guile provides what might be described as 'practical software freedom,'\
8 making it possible for users to customize an application to meet their\
9 needs without digging into the application's internals."
10
11HOMEPAGE = "http://www.gnu.org/software/guile/"
12SECTION = "devel"
13LICENSE = "GPLv3"
14LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
15
16SRC_URI = "${GNU_MIRROR}/guile/guile-${PV}.tar.gz \
17 file://debian/0002-Mark-Unused-modules-are-removed-gc-test-as-unresolve.patch \
18 file://debian/0003-Mark-mutex-with-owner-not-retained-threads-test-as-u.patch \
19 file://opensuse/guile-64bit.patch \
20 file://guile_2.0.6_fix_sed_error.patch \
21 file://arm_endianness.patch \
22 file://change-install-data-hook-to-install-exec-hook-in-gui.patch \
23 "
24
25# file://debian/0001-Change-guile-to-guile-X.Y-for-info-pages.patch
26# file://opensuse/guile-turn-off-gc-test.patch
27
28SRC_URI[md5sum] = "3438cd4415c0c43ca93a20e845eba7e2"
29SRC_URI[sha256sum] = "3ece055145a5020dd36b84f5fbccd4b3846a671960dd5ee55931555f03200950"
30
31PR = "r2"
32
33inherit autotools gettext
34BBCLASSEXTEND = "native"
35
36DEPENDS = "libunistring bdwgc gmp libtool libffi"
37# add guile-native only to the target recipe's DEPENDS
38DEPENDS += "${@['guile-native libatomics-ops', ''][d.getVar('PN', True) != 'guile']}"
39
40EXTRA_OECONF += "${@['--without-libltdl-prefix --without-libgmp-prefix', ''][bb.data.inherits_class('native',d)]}"
41
42do_configure_prepend() {
43 mkdir -p po
44}
45
46export GUILE_FOR_BUILD="${BUILD_SYS}-guile"
47
48do_compile_append() {
49 # just for target recipe
50 if [ "${PN}" = "guile" ]
51 then
52 sed -i -e s:${STAGING_DIR_TARGET}::g \
53 -e s:/${TARGET_SYS}::g \
54 -e s:-L/usr/lib::g \
55 -e s:-isystem/usr/include::g \
56 -e s:,/usr/lib:,\$\{libdir\}:g \
57 meta/guile-2.0.pc
58 fi
59}
60
61do_install_append_class-native() {
62 install -m 0755 ${D}${bindir}/guile ${D}${bindir}/${HOST_SYS}-guile
63
64 create_wrapper ${D}/${bindir}/guile \
65 GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \
66 GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache
67 create_wrapper ${D}${bindir}/${HOST_SYS}-guile \
68 GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \
69 GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache
70}
71
72SYSROOT_PREPROCESS_FUNCS = "guile_cross_config"
73
74guile_cross_config() {
75 # this is only for target recipe
76 if [ "${PN}" = "guile" ]
77 then
78 # Create guile-config returning target values instead of native values
79 install -d ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}
80 echo '#!'`which ${BUILD_SYS}-guile`$' \\\n--no-auto-compile -e main -s\n!#\n(define %guile-build-info '\'\( \
81 > guile-config.cross
82 sed -n -e 's:^[ \t]*{[ \t]*": (:' \
83 -e 's:",[ \t]*": . ":' \
84 -e 's:" *}, *\\:"):' \
85 -e 's:^.*cachedir.*$::' \
86 -e '/^ (/p' \
87 < libguile/libpath.h >> guile-config.cross
88 echo '))' >> guile-config.cross
89 cat meta/guile-config >> guile-config.cross
90 install guile-config.cross ${STAGING_BINDIR_CROSS}/guile-config
91 fi
92}
93
94# Guile needs the compiled files to be newer than the source, and it won't
95# auto-compile into the prefix even if it can write there, so touch them here as
96# sysroot is managed.
97SSTATEPOSTINSTFUNCS += "guile_sstate_postinst"
98guile_sstate_postinst() {
99 if [ "${BB_CURRENTTASK}" = "populate_sysroot" -o "${BB_CURRENTTASK}" = "populate_sysroot_setscene" ]
100 then
101 find ${STAGING_DIR_TARGET}/${libdir}/guile/2.0/ccache -type f | xargs touch
102 fi
103}