summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/guile/guile_2.0.3.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2012-05-01 09:31:01 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-09 21:42:51 +0100
commit3eff636ee86ce1f650625147d524b0c3429784e8 (patch)
tree52056a0cbd6781678045853db77fa23ced5072ac /meta/recipes-devtools/guile/guile_2.0.3.bb
parent1e6c1169fee55ec1c492865cb8187f5ed4b16590 (diff)
downloadpoky-3eff636ee86ce1f650625147d524b0c3429784e8.tar.gz
guile: upgrade from 2.0.3 to 2.0.5
(From OE-Core rev: 29afcb7ad976db62f9a46abf305a47a24a99dbda) Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/guile/guile_2.0.3.bb')
-rw-r--r--meta/recipes-devtools/guile/guile_2.0.3.bb88
1 files changed, 0 insertions, 88 deletions
diff --git a/meta/recipes-devtools/guile/guile_2.0.3.bb b/meta/recipes-devtools/guile/guile_2.0.3.bb
deleted file mode 100644
index 164ab8c647..0000000000
--- a/meta/recipes-devtools/guile/guile_2.0.3.bb
+++ /dev/null
@@ -1,88 +0,0 @@
1SUMMARY = "Guile is the GNU Ubiquitous Intelligent Language for Extensions."
2DESCRIPTION = "Guile is the GNU Ubiquitous Intelligent Language for Extensions,\
3 the official extension language for the GNU operating system.\
4 Guile is a library designed to help programmers create flexible applications.\
5 Using Guile in an application allows the application's functionality to be\
6 extended by users or other programmers with plug-ins, modules, or scripts.\
7 Guile provides what might be described as 'practical software freedom,'\
8 making it possible for users to customize an application to meet their\
9 needs without digging into the application's internals."
10
11HOMEPAGE = "http://www.gnu.org/software/guile/"
12SECTION = "devel"
13LICENSE = "GPLv3"
14LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
15
16SRC_URI = "${GNU_MIRROR}/guile/guile-${PV}.tar.gz \
17 file://debian/0001-Fix-the-SRFI-60-copy-bit-documentation.patch \
18 file://debian/0002-Define-_GNU_SOURCE-to-fix-the-GNU-kFreeBSD-build.patch \
19 file://debian/0003-Include-gc.h-rather-than-gc-gc_version.h-in-pthread-.patch \
20 file://opensuse/guile-64bit.patch \
21 file://opensuse/guile-turn-off-gc-test.patch \
22 "
23
24SRC_URI[md5sum] = "3b8b4e1083037f29d2c4704a6d55f2a8"
25SRC_URI[sha256sum] = "a53b21159befe3e89bbaca71e9e62cf00af0f49fcca297c407944b988d59eb08"
26
27PR = "r5"
28
29inherit autotools gettext
30BBCLASSEXTEND = "native"
31
32DEPENDS = "libunistring bdwgc gmp libtool libffi"
33# add guile-native only to the target recipe's DEPENDS
34DEPENDS += "${@['guile-native', ''][d.getVar('PN', True) != 'guile']}"
35
36EXTRA_OECONF += "${@['--without-libltdl-prefix --without-libgmp-prefix', ''][bb.data.inherits_class('native',d)]}"
37
38do_configure_prepend() {
39 mkdir -p po
40}
41
42export GUILE_FOR_BUILD="${BUILD_SYS}-guile"
43
44do_compile_append() {
45 # just for target recipe
46 if [ "${PN}" == "guile" ]
47 then
48 sed -i -e s:${STAGING_DIR_TARGET}::g \
49 -e s:/${TARGET_SYS}::g \
50 -e s:-L/usr/lib::g \
51 -e s:-isystem/usr/include::g \
52 -e s:,/usr/lib:,\$\{libdir\}:g \
53 meta/guile-2.0.pc
54 fi
55}
56
57do_install_append_virtclass-native() {
58 install -m 0755 ${D}${bindir}/guile ${D}${bindir}/${HOST_SYS}-guile
59
60 create_wrapper ${D}/${bindir}/guile \
61 GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \
62 GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache
63 create_wrapper ${D}${bindir}/${HOST_SYS}-guile
64 GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \
65 GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache
66}
67
68SYSROOT_PREPROCESS_FUNCS = "guile_cross_config"
69
70guile_cross_config() {
71 # this is only for target recipe
72 if [ "${PN}" == "guile" ]
73 then
74 # Create guile-config returning target values instead of native values
75 install -d ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}
76 echo '#!'`which ${BUILD_SYS}-guile`$' \\\n--no-auto-compile -e main -s\n!#\n(define %guile-build-info '\'\( \
77 > guile-config.cross
78 sed -n -e 's:^[ \t]*{[ \t]*": (:' \
79 -e 's:",[ \t]*": . ":' \
80 -e 's:" *}, *\\:"):' \
81 -e 's:^.*cachedir.*$::' \
82 -e '/^ (/p' \
83 < libguile/libpath.h >> guile-config.cross
84 echo '))' >> guile-config.cross
85 cat meta/guile-config >> guile-config.cross
86 install guile-config.cross ${STAGING_BINDIR_CROSS}/guile-config
87 fi
88}