summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/guile/guile_2.0.3.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2012-01-13 18:19:36 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-19 13:26:12 +0000
commit34f4ab18bdcac475ab703d00c3ccb989592633e3 (patch)
treefa60f1fb331a734be4a4fb6bd6c70ff8396f4bf3 /meta/recipes-devtools/guile/guile_2.0.3.bb
parent225a24a390beb07c9e2bf86f8e2102e929c66a56 (diff)
downloadpoky-34f4ab18bdcac475ab703d00c3ccb989592633e3.tar.gz
guile: new recipe for autogen
guile recipe is needed by autogen. Imported & updated the guile-cross-config generation & guile-2.0.pc manipulation code from the meta-oe guile recipe. (From OE-Core rev: 7726884826332387180cd24ebe565cd13a193e13) Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/guile/guile_2.0.3.bb')
-rw-r--r--meta/recipes-devtools/guile/guile_2.0.3.bb79
1 files changed, 79 insertions, 0 deletions
diff --git a/meta/recipes-devtools/guile/guile_2.0.3.bb b/meta/recipes-devtools/guile/guile_2.0.3.bb
new file mode 100644
index 0000000000..60fbe32c6f
--- /dev/null
+++ b/meta/recipes-devtools/guile/guile_2.0.3.bb
@@ -0,0 +1,79 @@
1SUMMARY = "Guile is the GNU Ubiquitous Intelligent Language for Extensions."
2DESCRIPTION = "Guile is the GNU Ubiquitous Intelligent Language for Extensions,\
3 the official extension language for the GNU operating system.\
4 Guile is a library designed to help programmers create flexible applications.\
5 Using Guile in an application allows the application's functionality to be\
6 extended by users or other programmers with plug-ins, modules, or scripts.\
7 Guile provides what might be described as "practical software freedom,"\
8 making it possible for users to customize an application to meet their\
9 needs without digging into the application's internals."
10
11HOMEPAGE = "http://www.gnu.org/software/guile/"
12SECTION = "devel"
13LICENSE = "GPLv3"
14LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
15
16SRC_URI = "${GNU_MIRROR}/guile/guile-${PV}.tar.gz \
17 file://debian/0001-Fix-the-SRFI-60-copy-bit-documentation.patch \
18 file://debian/0002-Define-_GNU_SOURCE-to-fix-the-GNU-kFreeBSD-build.patch \
19 file://debian/0003-Include-gc.h-rather-than-gc-gc_version.h-in-pthread-.patch \
20 file://opensuse/guile-64bit.patch \
21 file://opensuse/guile-turn-off-gc-test.patch \
22 "
23
24SRC_URI[md5sum] = "3b8b4e1083037f29d2c4704a6d55f2a8"
25SRC_URI[sha256sum] = "a53b21159befe3e89bbaca71e9e62cf00af0f49fcca297c407944b988d59eb08"
26
27PR = "r1"
28
29inherit autotools gettext
30BBCLASSEXTEND = "native"
31
32DEPENDS = "libunistring bdwgc gmp libtool libffi"
33# add guile-native only to the target recipe's DEPENDS
34DEPENDS += "${@['guile-native', ''][d.getVar('PN', 1) != 'guile']}"
35
36do_configure_prepend() {
37 mkdir -p po
38}
39
40export GUILE_FOR_BUILD=${BUILD_SYS}-guile
41
42do_compile_append() {
43 # just for target recipe
44 if [ "${PN}" == "guile" ]
45 then
46 sed -i -e s:${STAGING_DIR_TARGET}::g \
47 -e s:/${TARGET_SYS}::g \
48 -e s:-L/usr/lib::g \
49 -e s:-isystem/usr/include::g \
50 -e s:,/usr/lib:,\$\{libdir\}:g \
51 meta/guile-2.0.pc
52 fi
53}
54
55do_install_append_virtclass-native() {
56 install -m 0755 ${D}${bindir}/guile ${D}${bindir}/${HOST_SYS}-guile
57}
58
59SYSROOT_PREPROCESS_FUNCS = "guile_cross_config"
60
61guile_cross_config() {
62 # this is only for target recipe
63 if [ "${PN}" == "guile" ]
64 then
65 # Create guile-config returning target values instead of native values
66 install -d ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}
67 echo '#!'`which ${BUILD_SYS}-guile`$' \\\n--no-auto-compile -e main -s\n!#\n(define %guile-build-info '\'\( \
68 > guile-config.cross
69 sed -n -e 's:^[ \t]*{[ \t]*": (:' \
70 -e 's:",[ \t]*": . ":' \
71 -e 's:" *}, *\\:"):' \
72 -e 's:^.*cachedir.*$::' \
73 -e '/^ (/p' \
74 < libguile/libpath.h >> guile-config.cross
75 echo '))' >> guile-config.cross
76 cat meta/guile-config >> guile-config.cross
77 install guile-config.cross ${STAGING_BINDIR_CROSS}/guile-config
78 fi
79}