summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go_1.14.bb
diff options
context:
space:
mode:
authorPeter Morrow <pemorrow@linux.microsoft.com>2021-04-06 06:07:58 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-04-23 10:41:15 +0100
commitb0cb809fb9fe2828cf41ef1116952322c70a9e62 (patch)
treeeee3c01610a6682ab9c67c239281cba4d3c643f4 /meta/recipes-devtools/go/go_1.14.bb
parent1c0af77e5fd61f103f95f888499320f6bee05318 (diff)
downloadpoky-b0cb809fb9fe2828cf41ef1116952322c70a9e62.tar.gz
go_1.14: don't set -buildmode=pie when building for windows targets
go 1.14 for windows targets does not support -buildmode=pie, disable it and use the default buildmode instead. Support for -buildmode=pie for windows targets is added with go 1.15 (https://golang.org/doc/go1.15) which is added to poky in gatesgarth. (From OE-Core rev: a1b0631c4723d2a98eb9e80ec85a00bc46276783) Signed-off-by: Peter Morrow <pemorrow@linux.microsoft.com> Signed-off-by: Steve Sakoman <steve@sakoman.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/go/go_1.14.bb')
-rw-r--r--meta/recipes-devtools/go/go_1.14.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-devtools/go/go_1.14.bb b/meta/recipes-devtools/go/go_1.14.bb
index bc90a1329e..c17527998b 100644
--- a/meta/recipes-devtools/go/go_1.14.bb
+++ b/meta/recipes-devtools/go/go_1.14.bb
@@ -3,11 +3,11 @@ require go-target.inc
3 3
4export GOBUILDMODE="" 4export GOBUILDMODE=""
5export CGO_ENABLED_riscv64 = "" 5export CGO_ENABLED_riscv64 = ""
6# Add pie to GOBUILDMODE to satisfy "textrel" QA checking, but mips/riscv 6# Add pie to GOBUILDMODE to satisfy "textrel" QA checking, but
7# doesn't support -buildmode=pie, so skip the QA checking for mips/riscv and its 7# windows/mips/riscv doesn't support -buildmode=pie, so skip the QA checking
8# variants. 8# for windows/mips/riscv and their variants.
9python() { 9python() {
10 if 'mips' in d.getVar('TARGET_ARCH',True) or 'riscv' in d.getVar('TARGET_ARCH',True): 10 if 'mips' in d.getVar('TARGET_ARCH',True) or 'riscv' in d.getVar('TARGET_ARCH',True) or 'windows' in d.getVar('TARGET_GOOS', True):
11 d.appendVar('INSANE_SKIP_%s' % d.getVar('PN',True), " textrel") 11 d.appendVar('INSANE_SKIP_%s' % d.getVar('PN',True), " textrel")
12 else: 12 else:
13 d.setVar('GOBUILDMODE', 'pie') 13 d.setVar('GOBUILDMODE', 'pie')