summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go_1.11.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-10-29 16:21:15 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-14 11:14:39 +0000
commit88ac8e533438532ff6cad3285cdd16479e70642d (patch)
tree82f7a723bee4a9281731970032d7cb0b671f4f1f /meta/recipes-devtools/go/go_1.11.bb
parent07999325f94a60546212d37ffc9f4de7a3943214 (diff)
downloadpoky-88ac8e533438532ff6cad3285cdd16479e70642d.tar.gz
go 1.9/1.11: fix textrel qa warning for non mips arch
While building go itself, the go build system does not support to set `-buildmode=pie' from environment. Add GOBUILDMODE to support it which make PIE executables the default build mode, as PIE executables are required as of Yocto But mips doesn't support -buildmode=pie, so skip the QA checking for mips and its variants (From OE-Core rev: d11cb2ea0abfca4a5958ff4647f22a5b203113e5) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/go/go_1.11.bb')
-rw-r--r--meta/recipes-devtools/go/go_1.11.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go_1.11.bb b/meta/recipes-devtools/go/go_1.11.bb
index c67e2cb050..42cdb0430a 100644
--- a/meta/recipes-devtools/go/go_1.11.bb
+++ b/meta/recipes-devtools/go/go_1.11.bb
@@ -1,2 +1,14 @@
1require go-${PV}.inc 1require go-${PV}.inc
2require go-target.inc 2require go-target.inc
3
4export GOBUILDMODE=""
5
6# Add pie to GOBUILDMODE to satisfy "textrel" QA checking, but mips
7# doesn't support -buildmode=pie, so skip the QA checking for mips and its
8# variants.
9python() {
10 if 'mips' in d.getVar('TARGET_ARCH'):
11 d.appendVar('INSANE_SKIP_%s' % d.getVar('PN'), " textrel")
12 else:
13 d.setVar('GOBUILDMODE', 'pie')
14}