summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go-runtime_1.9.bb
diff options
context:
space:
mode:
authorMatt Madison <matt@madison.systems>2018-03-04 13:09:25 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-06 06:43:10 -0800
commit7a4ca89b557648d9aae30b405f6be09b4a383abe (patch)
treefb131b91c54b054ad525566d2da014abaa7c8f9f /meta/recipes-devtools/go/go-runtime_1.9.bb
parent26227695b350056225e9d309defdcd66573b79bb (diff)
downloadpoky-7a4ca89b557648d9aae30b405f6be09b4a383abe.tar.gz
go: update go 1.9 -> go 1.10
* Patches and recipes reworked for go 1.10's significant changes to its bootstrap and build steps. * Update go1.4 source tarball used for go-native bootstrapping to the version recommended in the current go documentation * Remove test data from installed sources to eliminate some packaging QA warnings * Set GOCACHE to 'off' to disable 1.10's build caching in the go recipes and bbclass * Update go_do_compile to compile both static and dynamic objects dynamic linking is in use, since go1.10's build tool is pickier about this (From OE-Core rev: 4fd749ca6450a4870be1c1e13802f084b6eb0db6) Signed-off-by: Matt Madison <matt@madison.systems> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/go/go-runtime_1.9.bb')
-rw-r--r--meta/recipes-devtools/go/go-runtime_1.9.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go-runtime_1.9.bb b/meta/recipes-devtools/go/go-runtime_1.9.bb
index 43b68b4e46..a99cc30f63 100644
--- a/meta/recipes-devtools/go/go-runtime_1.9.bb
+++ b/meta/recipes-devtools/go/go-runtime_1.9.bb
@@ -1,2 +1,23 @@
1require go-${PV}.inc 1require go-${PV}.inc
2require go-runtime.inc 2require go-runtime.inc
3
4export GO_TARGET_INSTALL = "std"
5export CC_FOR_TARGET = "${CC}"
6export CXX_FOR_TARGET = "${CXX}"
7
8do_compile() {
9 export GOBIN="${B}/bin"
10 export TMPDIR="$GOTMPDIR"
11 export CC=$BUILD_CC
12
13 cd src
14 ./make.bash --host-only
15 cp ${B}/pkg/tool/${BUILD_GOTUPLE}/go_bootstrap ${B}
16 rm -rf ${B}/pkg/${TARGET_GOTUPLE}
17 ./make.bash --target-only
18 if [ -n "${GO_DYNLINK}" ]; then
19 cp ${B}/go_bootstrap ${B}/pkg/tool/${BUILD_GOTUPLE}
20 GO_FLAGS="-buildmode=shared" GO_LDFLAGS="-extldflags \"${LDFLAGS}\"" ./make.bash --target-only
21 fi
22 cd ${B}
23}