summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go-dep_0.4.1.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-02-16 23:36:23 -0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-24 10:31:45 +0000
commitd96f1d2379a170f541b2ce637cb058015e55506b (patch)
treec019aa8ed72680001f8fee4bd320d3cfe04e0fc7 /meta/recipes-devtools/go/go-dep_0.4.1.bb
parentc4172f3f7645d43cd63d782772798f3e1138bd9e (diff)
downloadpoky-d96f1d2379a170f541b2ce637cb058015e55506b.tar.gz
go-dep: Upgrade 0.3.2 -> 0.4.1
The release was announced in Jan 24th 2018 and provides a number of features and bug fixes. The 0.4.1 restores the `dep prune` command support, which was dropped on 0.4.0, so existing scripts will continue to work. That said, it is advisable to change the scripts to use the new features of `dep ensure` as `dep prune` will be removed in future. (From OE-Core rev: d8467f2ce7e3ca2277108e388690b79789790839) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/go/go-dep_0.4.1.bb')
-rw-r--r--meta/recipes-devtools/go/go-dep_0.4.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go-dep_0.4.1.bb b/meta/recipes-devtools/go/go-dep_0.4.1.bb
new file mode 100644
index 0000000000..d82e637205
--- /dev/null
+++ b/meta/recipes-devtools/go/go-dep_0.4.1.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Dependency management tool for Golang"
2HOMEPAGE = "https://github.com/golang/dep"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=1bad315647751fab0007812f70d42c0d"
5
6GO_IMPORT = "github.com/golang/dep"
7SRC_URI = "git://${GO_IMPORT} \
8 file://0001-Add-support-for-mips-mips64.patch;patchdir=src/github.com/golang/dep \
9 "
10
11# Points to 0.4.1 tag
12SRCREV = "37d9ea0ac16f0e0a05afc3b60e1ac8c364b6c329"
13
14inherit go
15
16GO_INSTALL = "${GO_IMPORT}/cmd/dep"
17
18RDEPENDS_${PN}-dev += "bash"
19
20BBCLASSEXTEND = "native nativesdk"