summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/glide/glide_0.13.3.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2023-05-02 12:42:02 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-05-03 07:33:18 +0100
commit45269ffda1fcb966cf2f87748f62b328a7cfe4b6 (patch)
tree0d0ab3268bc554efd2c58fb9f1869a37c83c1ce5 /meta/recipes-devtools/glide/glide_0.13.3.bb
parent0d8b76c74f84a28c92f802376a78c9eb8ee92f53 (diff)
downloadpoky-45269ffda1fcb966cf2f87748f62b328a7cfe4b6.tar.gz
glide: remove as 'go mod' has become standard
(From OE-Core rev: 7870364e482bfae35fb647977c8e03bf3ef1e2a9) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/glide/glide_0.13.3.bb')
-rw-r--r--meta/recipes-devtools/glide/glide_0.13.3.bb43
1 files changed, 0 insertions, 43 deletions
diff --git a/meta/recipes-devtools/glide/glide_0.13.3.bb b/meta/recipes-devtools/glide/glide_0.13.3.bb
deleted file mode 100644
index db703c2d21..0000000000
--- a/meta/recipes-devtools/glide/glide_0.13.3.bb
+++ /dev/null
@@ -1,43 +0,0 @@
1SUMMARY = "Vendor Package Management for Golang"
2HOMEPAGE = "https://github.com/Masterminds/glide"
3DESCRIPTION = "Glide is a Vendor Package Management for Golang"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=54905cf894f8cc416a92f4fc350c35b2"
6
7GO_IMPORT = "github.com/Masterminds/glide"
8SRC_URI = "git://${GO_IMPORT};branch=master;protocol=https"
9SRCREV = "8ed5b9292379d86c39592a7e6a58eb9c903877cf"
10
11inherit go
12
13# New Go versions has Go modules support enabled by default and cause the Glide
14# tool build to fail.
15export GO111MODULE = "off"
16
17RDEPENDS:${PN}-dev += "bash"
18RDEPENDS:${PN}-ptest += "bash"
19
20BBCLASSEXTEND = "native nativesdk"
21
22# for x86 ends with textrel in ${PN}
23# http://errors.yoctoproject.org/Errors/Details/185631/
24# ERROR: QA Issue: ELF binary '/work/i586-oe-linux/glide/0.13.1-r0/packages-split/glide/usr/bin/glide' has relocations in .text [textrel]
25INSANE_SKIP:${PN} += "textrel"
26
27# for aarch64 ends with textrel in ${PN}-ptest
28# http://errors.yoctoproject.org/Errors/Details/185633/
29# ERROR: QA Issue: ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/glide.test' has relocations in .text
30# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/dependency/dependency.test' has relocations in .text
31# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/repo/repo.test' has relocations in .text
32# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/mirrors/mirrors.test' has relocations in .text
33# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/cfg/cfg.test' has relocations in .text
34# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/godep/strip/strip.test' has relocations in .text
35# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/path/path.test' has relocations in .text
36# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/tree/tree.test' has relocations in .text
37# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/util/util.test' has relocations in .text
38# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/action/action.test' has relocations in .text
39# ELF binary '/work/aarch64-oe-linux/glide/0.13.1-r0/packages-split/glide-ptest/usr/lib/glide/ptest/github.com/Masterminds/glide/cache/cache.test' has relocations in .text [textrel]
40INSANE_SKIP:${PN}-ptest += "textrel"
41
42# fails to run task compile_ptest_base on mips
43PTEST_ENABLED:mipsarch = "0"