summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gdb/gdb_14.2.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-03-03 19:57:27 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-03-05 12:24:49 +0000
commitf629e7ef1b8b6d0c209c228ed201d3c72689ffa4 (patch)
tree76403025dd5922352b1428c2a6532da6b6d68c8d /meta/recipes-devtools/gdb/gdb_14.2.bb
parent4f1c141ceb21ab314933c49d469c9ed77cbb283a (diff)
downloadpoky-f629e7ef1b8b6d0c209c228ed201d3c72689ffa4.tar.gz
gdb: Upgrade 14.1 -> 14.2
BugFix release This is a minor corrective release over GDB 14.1, fixing the following issues: PR symtab/31112 (DLL export forwarding is broken) PR c++/31128 (gdb crashes when trying to print a global variable stub without a running inferior) PR tdep/31254 ([gdb/tdep, arm] FAIL: gdb.threads/staticthreads.exp: up 10) PR gdb/31256 (Crash with basic 'list .') PR python/31366 (Frame.static_link() segfaults) (From OE-Core rev: f5483fe1f9682d18f92788ef71618a00bd6dfee0) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gdb/gdb_14.2.bb')
-rw-r--r--meta/recipes-devtools/gdb/gdb_14.2.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_14.2.bb b/meta/recipes-devtools/gdb/gdb_14.2.bb
new file mode 100644
index 0000000000..9c6db4ca2c
--- /dev/null
+++ b/meta/recipes-devtools/gdb/gdb_14.2.bb
@@ -0,0 +1,39 @@
1require gdb-common.inc
2
3inherit gettext pkgconfig
4
5#LDFLAGS:append = " -s"
6#export CFLAGS:append=" -L${STAGING_LIBDIR}"
7
8# cross-canadian must not see this
9PACKAGES =+ "gdbserver"
10FILES:gdbserver = "${bindir}/gdbserver"
11
12require gdb.inc
13
14inherit python3-dir
15
16EXTRA_OEMAKE:append:libc-musl = "\
17 gt_cv_func_gnugettext1_libc=yes \
18 gt_cv_func_gnugettext2_libc=yes \
19 gl_cv_func_working_strerror=yes \
20 gl_cv_func_strerror_0_works=yes \
21 gl_cv_func_gettimeofday_clobber=no \
22 "
23
24do_configure:prepend() {
25 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
26 cat > ${WORKDIR}/python << EOF
27#!/bin/sh
28case "\$2" in
29 --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}/" ;;
30 --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}${PYTHON_ABI}" ;;
31 --exec-prefix) echo "${exec_prefix}" ;;
32 *) exit 1 ;;
33esac
34exit 0
35EOF
36 chmod +x ${WORKDIR}/python
37 fi
38}
39