summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gcc/gcc_9.3.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-03-12 16:08:40 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-03-13 13:35:16 +0000
commit901a93885fccd2640b1205d84959a4e894f8f224 (patch)
tree9cf52a70102c4043bebdc341f8c9fc5f1ac19581 /meta/recipes-devtools/gcc/gcc_9.3.bb
parent350979b2787a5472a03781b0dbc25e0364136a8d (diff)
downloadpoky-901a93885fccd2640b1205d84959a4e894f8f224.tar.gz
gcc: Upgrade to 9.3 bugfix release
This brings ~157 bugfixes [1] to gcc-9 with no features Drop backports which are already part of the release now [1] https://gcc.gnu.org/bugzilla/buglist.cgi?bug_status=RESOLVED&list_id=260610&resolution=FIXED&target_milestone=9.3 (From OE-Core rev: caf80e4e245132bdc3bbe219b567013f2c5d2f46) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc_9.3.bb')
-rw-r--r--meta/recipes-devtools/gcc/gcc_9.3.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc_9.3.bb b/meta/recipes-devtools/gcc/gcc_9.3.bb
new file mode 100644
index 0000000000..7d93590588
--- /dev/null
+++ b/meta/recipes-devtools/gcc/gcc_9.3.bb
@@ -0,0 +1,14 @@
1require recipes-devtools/gcc/gcc-${PV}.inc
2require gcc-target.inc
3
4# Building with thumb enabled on armv4t armv5t fails with
5# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7438:(.text.unlikely+0x2fa): relocation truncated to fit: R_ARM_THM_CALL against symbol `fancy_abort(char const*, int, char const*)' defined in .glue_7 section in linker stubs
6# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7442:(.text.unlikely+0x318): additional relocation overflows omitted from the output
7ARM_INSTRUCTION_SET_armv4 = "arm"
8ARM_INSTRUCTION_SET_armv5 = "arm"
9
10ARMFPARCHEXT_armv6 = "${@'+fp' if d.getVar('TARGET_FPU') == 'hard' else ''}"
11ARMFPARCHEXT_armv7a = "${@'+fp' if d.getVar('TARGET_FPU') == 'hard' else ''}"
12ARMFPARCHEXT_armv7ve = "${@'+fp' if d.getVar('TARGET_FPU') == 'hard' else ''}"
13
14BBCLASSEXTEND = "nativesdk"