summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gcc/gcc_13.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-04-27 11:52:53 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-05-26 07:54:17 +0100
commit17085d769f40537937bf4ec20b4651fc8fc74e2f (patch)
tree16f9039e7fcd2e30f9833513c01d9c1be1032a94 /meta/recipes-devtools/gcc/gcc_13.1.bb
parentdeaedea295042df3e956660e43dbc871a8fa42d4 (diff)
downloadpoky-17085d769f40537937bf4ec20b4651fc8fc74e2f.tar.gz
gcc: Upgrade to GCC 13.1 release
- Package libhwasan_preinit.o, its available on some arches e.g. x86_64 on gcc13+ - GCC 13 Porting guide [1] and major changes [2] and detailed documentation [3] - Fix aarch64 cross build when S != B [1] https://www.gnu.org/software/gcc/gcc-13/porting_to.html [2] https://www.gnu.org/software/gcc/gcc-13/changes.html [3] https://gcc.gnu.org/onlinedocs/13.1.0/ (From OE-Core rev: b80c020eaeaaae82e5b32209ca8608b36eaaee40) (From OE-Core rev: bea46612fd9106cc5b46eb1d81623b6492563c13) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc_13.1.bb')
-rw-r--r--meta/recipes-devtools/gcc/gcc_13.1.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc_13.1.bb b/meta/recipes-devtools/gcc/gcc_13.1.bb
new file mode 100644
index 0000000000..255fe552bd
--- /dev/null
+++ b/meta/recipes-devtools/gcc/gcc_13.1.bb
@@ -0,0 +1,14 @@
1require recipes-devtools/gcc/gcc-${PV}.inc
2require gcc-target.inc
3
4# Building with thumb enabled on armv4t armv5t fails with
5# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7438:(.text.unlikely+0x2fa): relocation truncated to fit: R_ARM_THM_CALL against symbol `fancy_abort(char const*, int, char const*)' defined in .glue_7 section in linker stubs
6# | gcc-4.8.1-r0/gcc-4.8.1/gcc/cp/decl.c:7442:(.text.unlikely+0x318): additional relocation overflows omitted from the output
7ARM_INSTRUCTION_SET:armv4 = "arm"
8ARM_INSTRUCTION_SET:armv5 = "arm"
9
10ARMFPARCHEXT:armv6 = "${@'+fp' if d.getVar('TARGET_FPU') == 'hard' else ''}"
11ARMFPARCHEXT:armv7a = "${@'+fp' if d.getVar('TARGET_FPU') == 'hard' else ''}"
12ARMFPARCHEXT:armv7ve = "${@'+fp' if d.getVar('TARGET_FPU') == 'hard' else ''}"
13
14BBCLASSEXTEND = "nativesdk"