summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/flex/flex_2.6.0.bb
diff options
context:
space:
mode:
authorTrevor Woerner <twoerner@gmail.com>2017-02-10 15:13:08 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-01 23:27:06 +0000
commit2d238896de3dd946022eab4c447243bd33641a14 (patch)
tree77484dbc5ebfd07641beca27f2e73ba081e1fbee /meta/recipes-devtools/flex/flex_2.6.0.bb
parent27397190718922e20920895678b172ff5cdaba69 (diff)
downloadpoky-2d238896de3dd946022eab4c447243bd33641a14.tar.gz
Revert "flex: upgrade to 2.6.2"
This reverts commit 3632abd01abb8dfff230e18f828af705da488f97. Multiple people have expressed issues with flex-2.6.2; personally I had problems compiling libsepol from meta-selinux (for libselinux). I tried upgrading to flex-2.6.3, but that caused binutils-cross_2.27 to fail. The simplest for now is to downgrade to flex-2.6.0. (From OE-Core rev: b45776bbdafa6f6afe815714ac329494ad57e644) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/flex/flex_2.6.0.bb')
-rw-r--r--meta/recipes-devtools/flex/flex_2.6.0.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta/recipes-devtools/flex/flex_2.6.0.bb b/meta/recipes-devtools/flex/flex_2.6.0.bb
new file mode 100644
index 0000000000..ab35b09f99
--- /dev/null
+++ b/meta/recipes-devtools/flex/flex_2.6.0.bb
@@ -0,0 +1,62 @@
1SUMMARY = "Flex (The Fast Lexical Analyzer)"
2DESCRIPTION = "Flex is a fast lexical analyser generator. Flex is a tool for generating programs that recognize \
3lexical patterns in text."
4HOMEPAGE = "http://sourceforge.net/projects/flex/"
5SECTION = "devel"
6LICENSE = "BSD"
7
8DEPENDS = "${@bb.utils.contains('PTEST_ENABLED', '1', 'bison-native flex-native', '', d)}"
9BBCLASSEXTEND = "native nativesdk"
10
11LIC_FILES_CHKSUM = "file://COPYING;md5=e4742cf92e89040b39486a6219b68067"
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/flex/flex-${PV}.tar.bz2 \
14 file://run-ptest \
15 file://do_not_create_pdf_doc.patch \
16 file://0001-tests-add-a-target-for-building-tests-without-runnin.patch \
17 file://0002-avoid-c-comments-in-c-code-fails-with-gcc-6.patch \
18 file://CVE-2016-6354.patch \
19 ${@bb.utils.contains('PTEST_ENABLED', '1', '', 'file://disable-tests.patch', d)} \
20 "
21
22SRC_URI[md5sum] = "266270f13c48ed043d95648075084d59"
23SRC_URI[sha256sum] = "24e611ef5a4703a191012f80c1027dc9d12555183ce0ecd46f3636e587e9b8e9"
24
25# Flex has moved to github from 2.6.1 onwards
26UPSTREAM_CHECK_URI = "https://github.com/westes/flex/releases"
27UPSTREAM_CHECK_REGEX = "flex-(?P<pver>\d+(\.\d+)+)\.tar"
28
29inherit autotools gettext texinfo ptest
30
31M4 = "${bindir}/m4"
32M4_class-native = "${STAGING_BINDIR_NATIVE}/m4"
33EXTRA_OECONF += "ac_cv_path_M4=${M4}"
34EXTRA_OEMAKE += "m4=${STAGING_BINDIR_NATIVE}/m4"
35
36EXTRA_OEMAKE += "${@bb.utils.contains('PTEST_ENABLED', '1', 'FLEX=${STAGING_BINDIR_NATIVE}/flex', '', d)}"
37
38do_install_append_class-native() {
39 create_wrapper ${D}/${bindir}/flex M4=${M4}
40}
41
42do_install_append_class-nativesdk() {
43 create_wrapper ${D}/${bindir}/flex M4=${M4}
44}
45
46RDEPENDS_${PN} += "m4"
47RDEPENDS_${PN}-ptest += "bash gawk"
48
49do_compile_ptest() {
50 oe_runmake -C ${B}/tests -f ${B}/tests/Makefile top_builddir=${B} INCLUDES=-I${S}/src buildtests
51}
52
53do_install_ptest() {
54 mkdir -p ${D}${PTEST_PATH}/build-aux/
55 cp ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/
56 cp -r ${S}/tests/* ${D}${PTEST_PATH}
57 cp -r ${B}/tests/* ${D}${PTEST_PATH}
58 sed -e 's/^Makefile:/_Makefile:/' \
59 -e 's/^srcdir = \(.*\)/srcdir = ./' -e 's/^top_srcdir = \(.*\)/top_srcdir = ./' \
60 -e 's/^builddir = \(.*\)/builddir = ./' -e 's/^top_builddir = \(.*\)/top_builddir = ./' \
61 -i ${D}${PTEST_PATH}/Makefile
62}