summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/file/file_5.40.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2021-10-25 22:26:54 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-27 09:46:41 +0100
commit56da9f74f7030085088f0cab53523b188b1d90c9 (patch)
tree08bdc0d46df66bf08666034ea2c81d117589fea2 /meta/recipes-devtools/file/file_5.40.bb
parent7f6b6dd2744206c6563319b6cb4012fae0c78cc9 (diff)
downloadpoky-56da9f74f7030085088f0cab53523b188b1d90c9.tar.gz
file: upgrade 5.40 -> 5.41
(From OE-Core rev: cf501dd94e16e4dfad7df6e57ef6b5bd6ab6d7d1) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/file/file_5.40.bb')
-rw-r--r--meta/recipes-devtools/file/file_5.40.bb54
1 files changed, 0 insertions, 54 deletions
diff --git a/meta/recipes-devtools/file/file_5.40.bb b/meta/recipes-devtools/file/file_5.40.bb
deleted file mode 100644
index 32b61f4f39..0000000000
--- a/meta/recipes-devtools/file/file_5.40.bb
+++ /dev/null
@@ -1,54 +0,0 @@
1SUMMARY = "File classification tool"
2DESCRIPTION = "File attempts to classify files depending \
3on their contents and prints a description if a match is found."
4HOMEPAGE = "http://www.darwinsys.com/file/"
5SECTION = "console/utils"
6
7# two clause BSD
8LICENSE = "BSD-2-Clause"
9LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=0251eaec1188b20d9a72c502ecfdda1b"
10
11DEPENDS = "file-replacement-native"
12DEPENDS:class-native = "bzip2-replacement-native"
13
14SRC_URI = "git://github.com/file/file.git"
15
16SRCREV = "f49fda6f52a9477d817dbd9c06afab02daf025f8"
17S = "${WORKDIR}/git"
18
19inherit autotools update-alternatives
20
21PACKAGECONFIG ??= "bz2 lzma zlib"
22PACKAGECONFIG[bz2] = "--enable-bzlib, --disable-bzlib, bzip2"
23PACKAGECONFIG[lzma] = "--enable-xzlib, --disable-xzlib, xz"
24PACKAGECONFIG[zlib] = "--enable-zlib, --disable-zlib, zlib"
25
26EXTRA_OECONF += "--disable-libseccomp"
27
28ALTERNATIVE:${PN} = "file"
29ALTERNATIVE_LINK_NAME[file] = "${bindir}/file"
30
31EXTRA_OEMAKE:append:class-target = " -e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file"
32EXTRA_OEMAKE:append:class-nativesdk = " -e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file"
33
34FILES:${PN} += "${datadir}/misc/*.mgc"
35
36do_compile:append:class-native() {
37 oe_runmake check
38}
39
40do_install:append:class-native() {
41 create_cmdline_wrapper ${D}/${bindir}/file \
42 --magic-file ${datadir}/misc/magic.mgc
43}
44
45do_install:append:class-nativesdk() {
46 create_cmdline_wrapper ${D}/${bindir}/file \
47 --magic-file ${datadir}/misc/magic.mgc
48}
49
50BBCLASSEXTEND = "native nativesdk"
51PROVIDES:append:class-native = " file-replacement-native"
52# Don't use NATIVE_PACKAGE_PATH_SUFFIX as that hides libmagic from anyone who
53# depends on file-replacement-native.
54bindir:append:class-native = "/file-native"