summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/file/file_5.40.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2021-04-08 13:40:50 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-04-18 11:37:25 +0100
commit3db91ef623024f0f03af362e2677baab5c4cbc4e (patch)
tree6ef93039720e3b91a54ea2ed9145cb035ad5f840 /meta/recipes-devtools/file/file_5.40.bb
parent565cbd773d3c72835c60b5979b9dabd26870d6b2 (diff)
downloadpoky-3db91ef623024f0f03af362e2677baab5c4cbc4e.tar.gz
file: upgrade 5.39 -> 5.40
0001-src-compress.c-correct-header-define-for-xz-lzma.patch removed since it is included in 5.40 (From OE-Core rev: ae73c5fa666c0e0a7d1d7a04acd6246542b744aa) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/file/file_5.40.bb')
-rw-r--r--meta/recipes-devtools/file/file_5.40.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file_5.40.bb b/meta/recipes-devtools/file/file_5.40.bb
new file mode 100644
index 0000000000..ec79839bd2
--- /dev/null
+++ b/meta/recipes-devtools/file/file_5.40.bb
@@ -0,0 +1,54 @@
1SUMMARY = "File classification tool"
2DESCRIPTION = "File attempts to classify files depending \
3on their contents and prints a description if a match is found."
4HOMEPAGE = "http://www.darwinsys.com/file/"
5SECTION = "console/utils"
6
7# two clause BSD
8LICENSE = "BSD-2-Clause"
9LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=0251eaec1188b20d9a72c502ecfdda1b"
10
11DEPENDS = "file-replacement-native"
12DEPENDS_class-native = "bzip2-replacement-native"
13
14SRC_URI = "git://github.com/file/file.git"
15
16SRCREV = "f49fda6f52a9477d817dbd9c06afab02daf025f8"
17S = "${WORKDIR}/git"
18
19inherit autotools update-alternatives
20
21PACKAGECONFIG ??= "bz2 lzma zlib"
22PACKAGECONFIG[bz2] = "--enable-bzlib, --disable-bzlib, bzip2"
23PACKAGECONFIG[lzma] = "--enable-xzlib, --disable-xzlib, xz"
24PACKAGECONFIG[zlib] = "--enable-zlib, --disable-zlib, zlib"
25
26EXTRA_OECONF += "--disable-libseccomp"
27
28ALTERNATIVE_${PN} = "file"
29ALTERNATIVE_LINK_NAME[file] = "${bindir}/file"
30
31EXTRA_OEMAKE_append_class-target = " -e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file"
32EXTRA_OEMAKE_append_class-nativesdk = " -e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file"
33
34FILES_${PN} += "${datadir}/misc/*.mgc"
35
36do_compile_append_class-native() {
37 oe_runmake check
38}
39
40do_install_append_class-native() {
41 create_cmdline_wrapper ${D}/${bindir}/file \
42 --magic-file ${datadir}/misc/magic.mgc
43}
44
45do_install_append_class-nativesdk() {
46 create_cmdline_wrapper ${D}/${bindir}/file \
47 --magic-file ${datadir}/misc/magic.mgc
48}
49
50BBCLASSEXTEND = "native nativesdk"
51PROVIDES_append_class-native = " file-replacement-native"
52# Don't use NATIVE_PACKAGE_PATH_SUFFIX as that hides libmagic from anyone who
53# depends on file-replacement-native.
54bindir_append_class-native = "/file-native"