summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/file/file_5.38.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-01-20 04:26:44 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-27 16:48:08 +0000
commitde1fac5dd7af7b774775151381ae33e28d9ee4f3 (patch)
treeda6ea7215b71428def97f9fef94427d277ff52c4 /meta/recipes-devtools/file/file_5.38.bb
parent54c5b375d17e37ea0f0e8256f39bb056da7ea9c2 (diff)
downloadpoky-de1fac5dd7af7b774775151381ae33e28d9ee4f3.tar.gz
file: upgrade 5.37 -> 5.38
CVE-2019-18218.patch Removed since it is included in 5.38. (From OE-Core rev: 2ac297f8906354bf3a1578b5e78df040b4712b81) Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/file/file_5.38.bb')
-rw-r--r--meta/recipes-devtools/file/file_5.38.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file_5.38.bb b/meta/recipes-devtools/file/file_5.38.bb
new file mode 100644
index 0000000000..99c75988c2
--- /dev/null
+++ b/meta/recipes-devtools/file/file_5.38.bb
@@ -0,0 +1,49 @@
1SUMMARY = "File classification tool"
2DESCRIPTION = "File attempts to classify files depending \
3on their contents and prints a description if a match is found."
4HOMEPAGE = "http://www.darwinsys.com/file/"
5SECTION = "console/utils"
6
7# two clause BSD
8LICENSE = "BSD-2-Clause"
9LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=0251eaec1188b20d9a72c502ecfdda1b"
10
11DEPENDS = "zlib file-replacement-native"
12DEPENDS_class-native = "zlib-native"
13
14SRC_URI = "git://github.com/file/file.git"
15
16SRCREV = "ec41083645689a787cdd00cb3b5bf578aa79e46c"
17S = "${WORKDIR}/git"
18
19inherit autotools update-alternatives
20
21EXTRA_OECONF += "--disable-libseccomp"
22
23ALTERNATIVE_${PN} = "file"
24ALTERNATIVE_LINK_NAME[file] = "${bindir}/file"
25
26EXTRA_OEMAKE_append_class-target = "-e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file"
27EXTRA_OEMAKE_append_class-nativesdk = "-e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file"
28
29FILES_${PN} += "${datadir}/misc/*.mgc"
30
31do_compile_append_class-native() {
32 oe_runmake check
33}
34
35do_install_append_class-native() {
36 create_cmdline_wrapper ${D}/${bindir}/file \
37 --magic-file ${datadir}/misc/magic.mgc
38}
39
40do_install_append_class-nativesdk() {
41 create_cmdline_wrapper ${D}/${bindir}/file \
42 --magic-file ${datadir}/misc/magic.mgc
43}
44
45BBCLASSEXTEND = "native nativesdk"
46PROVIDES_append_class-native = " file-replacement-native"
47# Don't use NATIVE_PACKAGE_PATH_SUFFIX as that hides libmagic from anyone who
48# depends on file-replacement-native.
49bindir_append_class-native = "/file-native"