summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/file/file_5.37.bb
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2019-05-28 18:25:04 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-29 12:54:12 +0100
commit66030644e0cfa1ceff66b3d880bb828127c45d1d (patch)
tree4407a1f8cf80e82f1c59306fff652eb0a27cd2ae /meta/recipes-devtools/file/file_5.37.bb
parent124ac408d46b78814c2a397631aa74e1c6eeff6c (diff)
downloadpoky-66030644e0cfa1ceff66b3d880bb828127c45d1d.tar.gz
file: update to 5.37
(From OE-Core rev: 127d706d7fe5d29c500ab6f81bc6d97982209bf6) Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/file/file_5.37.bb')
-rw-r--r--meta/recipes-devtools/file/file_5.37.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file_5.37.bb b/meta/recipes-devtools/file/file_5.37.bb
new file mode 100644
index 0000000000..803aa9a271
--- /dev/null
+++ b/meta/recipes-devtools/file/file_5.37.bb
@@ -0,0 +1,46 @@
1SUMMARY = "File classification tool"
2DESCRIPTION = "File attempts to classify files depending \
3on their contents and prints a description if a match is found."
4HOMEPAGE = "http://www.darwinsys.com/file/"
5SECTION = "console/utils"
6
7# two clause BSD
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=0251eaec1188b20d9a72c502ecfdda1b"
10
11DEPENDS = "zlib file-replacement-native"
12DEPENDS_class-native = "zlib-native"
13
14# Blacklist a bogus tag in upstream check
15UPSTREAM_CHECK_GITTAGREGEX = "FILE(?P<pver>(?!6_23).+)"
16
17SRC_URI = "git://github.com/file/file.git"
18
19SRCREV = "a0d5b0e4e9f97d74a9911e95cedd579852e25398"
20S = "${WORKDIR}/git"
21
22inherit autotools update-alternatives
23
24ALTERNATIVE_${PN} = "file"
25ALTERNATIVE_LINK_NAME[file] = "${bindir}/file"
26
27EXTRA_OEMAKE_append_class-target = "-e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file"
28EXTRA_OEMAKE_append_class-nativesdk = "-e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file"
29
30FILES_${PN} += "${datadir}/misc/*.mgc"
31
32do_install_append_class-native() {
33 create_cmdline_wrapper ${D}/${bindir}/file \
34 --magic-file ${datadir}/misc/magic.mgc
35}
36
37do_install_append_class-nativesdk() {
38 create_cmdline_wrapper ${D}/${bindir}/file \
39 --magic-file ${datadir}/misc/magic.mgc
40}
41
42BBCLASSEXTEND = "native nativesdk"
43PROVIDES_append_class-native = " file-replacement-native"
44# Don't use NATIVE_PACKAGE_PATH_SUFFIX as that hides libmagic from anyone who
45# depends on file-replacement-native.
46bindir_append_class-native = "/file-native"