summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/file/file_5.21.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-12-21 21:28:23 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-23 10:18:19 +0000
commit7d8fe6df4dcba34883d27ff03b67f3f169148a4e (patch)
tree8a2451ce291ad7aee49df1cce1da271d6306a9a7 /meta/recipes-devtools/file/file_5.21.bb
parente1858932f98c1ec192479b9a5dcad7b39cbd97ec (diff)
downloadpoky-7d8fe6df4dcba34883d27ff03b67f3f169148a4e.tar.gz
file: upgrade to 5.21
* Upgrade to 5.21. * The debian-742262.patch is still needed. (From OE-Core rev: 9f336e07df7e273c55f0c7a451604a3500b4c6ab) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/file/file_5.21.bb')
-rw-r--r--meta/recipes-devtools/file/file_5.21.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-devtools/file/file_5.21.bb b/meta/recipes-devtools/file/file_5.21.bb
new file mode 100644
index 0000000000..702ea87343
--- /dev/null
+++ b/meta/recipes-devtools/file/file_5.21.bb
@@ -0,0 +1,35 @@
1SUMMARY = "File classification tool"
2DESCRIPTION = "File attempts to classify files depending \
3on their contents and prints a description if a match is found."
4HOMEPAGE = "http://www.darwinsys.com/file/"
5SECTION = "console/utils"
6
7# two clause BSD
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=6a7382872edb68d33e1a9398b6e03188"
10
11DEPENDS = "zlib file-native"
12DEPENDS_class-native = "zlib-native"
13
14SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
15 file://debian-742262.patch \
16 "
17
18SRC_URI[md5sum] = "549fe96e09041eabece9de2bb28ef923"
19SRC_URI[sha256sum] = "1a48741d3923c4cc73267109b8a396c0ce3aebe004181f3efb1b0a228d230bb6"
20
21inherit autotools
22
23FILES_${PN} += "${datadir}/misc/*.mgc"
24
25do_install_append_class-native() {
26 create_cmdline_wrapper ${D}/${bindir}/file \
27 --magic-file ${datadir}/misc/magic.mgc
28}
29
30do_install_append_class-nativesdk() {
31 create_cmdline_wrapper ${D}/${bindir}/file \
32 --magic-file ${datadir}/misc/magic.mgc
33}
34
35BBCLASSEXTEND = "native nativesdk"