summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/fdisk/gptfdisk_1.0.10.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2024-03-13 18:33:21 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-16 08:07:01 +0100
commite55b3e209a0f7582401bfb6c7efa34fe6d0f0960 (patch)
treef158b208f483bfaa96e36228f5f168a29aab29ba /meta/recipes-devtools/fdisk/gptfdisk_1.0.10.bb
parent1cfb2dc0def0eb5cd5698262a0a2e1c060ac4d00 (diff)
downloadpoky-e55b3e209a0f7582401bfb6c7efa34fe6d0f0960.tar.gz
gptfdisk: update 1.0.9 -> 1.0.10
(From OE-Core rev: d41178f9fea7e4121f582eaec68a6aa308e71b6e) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/fdisk/gptfdisk_1.0.10.bb')
-rw-r--r--meta/recipes-devtools/fdisk/gptfdisk_1.0.10.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-devtools/fdisk/gptfdisk_1.0.10.bb b/meta/recipes-devtools/fdisk/gptfdisk_1.0.10.bb
new file mode 100644
index 0000000000..ba891931ac
--- /dev/null
+++ b/meta/recipes-devtools/fdisk/gptfdisk_1.0.10.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Utility for modifying GPT disk partitioning"
2DESCRIPTION = "GPT fdisk is a disk partitioning tool loosely modeled on Linux fdisk, but used for modifying GUID Partition Table (GPT) disks. The related FixParts utility fixes some common problems on Master Boot Record (MBR) disks."
3HOMEPAGE = "https://sourceforge.net/projects/gptfdisk/"
4
5LICENSE = "GPL-2.0-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
7
8DEPENDS = "util-linux"
9
10SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${PV}/${BP}.tar.gz \
11 file://0001-gptcurses-correctly-include-curses.h.patch \
12 "
13SRC_URI[sha256sum] = "2abed61bc6d2b9ec498973c0440b8b804b7a72d7144069b5a9209b2ad693a282"
14
15UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/gptfdisk/files/gptfdisk/"
16UPSTREAM_CHECK_REGEX = "/gptfdisk/(?P<pver>(\d+[\.\-_]*)+)/"
17
18EXTRA_OEMAKE = "'CC=${CC}' 'CXX=${CXX}' gdisk fixparts ${PACKAGECONFIG_CONFARGS}"
19
20PACKAGECONFIG ??= "ncurses popt"
21PACKAGECONFIG[ncurses] = "cgdisk,,ncurses"
22PACKAGECONFIG[popt] = "sgdisk,,popt"
23
24do_install() {
25 install -d ${D}${sbindir}
26 for f in cgdisk sgdisk; do
27 if [ -x $f ]; then
28 install -m 0755 $f ${D}${sbindir}
29 fi
30 done
31 install -m 0755 gdisk ${D}${sbindir}
32 install -m 0755 fixparts ${D}${sbindir}
33}
34
35BBCLASSEXTEND = "native nativesdk"