summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/fdisk/gptfdisk_1.0.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-12-16 17:04:02 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-28 09:25:14 +0000
commit4c98105f76a426abdcd8ed587fc6967df461443f (patch)
tree484e77baff06ed750824df90970cf8dbf5c03f5e /meta/recipes-devtools/fdisk/gptfdisk_1.0.1.bb
parentedde9afcf9b5e581af8f4f455fc39ff9eb30c672 (diff)
downloadpoky-4c98105f76a426abdcd8ed587fc6967df461443f.tar.gz
gptfdisk: update to 1.0.1
(From OE-Core rev: 1d82a2cfa1c5243d0e5a600a2aa063f1a7a667ba) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/fdisk/gptfdisk_1.0.1.bb')
-rw-r--r--meta/recipes-devtools/fdisk/gptfdisk_1.0.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/fdisk/gptfdisk_1.0.1.bb b/meta/recipes-devtools/fdisk/gptfdisk_1.0.1.bb
new file mode 100644
index 0000000000..9f1daf3603
--- /dev/null
+++ b/meta/recipes-devtools/fdisk/gptfdisk_1.0.1.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Utility for modifying GPT disk partitioning"
2DESCRIPTION = "GPT fdisk is a disk partitioning tool loosely modeled on Linux fdisk, but used for modifying GUID Partition Table (GPT) disks. The related FixParts utility fixes some common problems on Master Boot Record (MBR) disks."
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
6
7DEPENDS = "util-linux popt ncurses"
8
9SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${PV}/${BP}.tar.gz"
10SRC_URI[md5sum] = "d7f3d306b083123bcc6f5941efade586"
11SRC_URI[sha256sum] = "864c8aee2efdda50346804d7e6230407d5f42a8ae754df70404dd8b2fdfaeac7"
12
13UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/gptfdisk/files/gptfdisk/"
14UPSTREAM_CHECK_REGEX = "/gptfdisk/(?P<pver>(\d+[\.\-_]*)+)/"
15
16do_install() {
17 install -d ${D}${sbindir}
18 install -m 0755 cgdisk ${D}${sbindir}
19 install -m 0755 gdisk ${D}${sbindir}
20 install -m 0755 sgdisk ${D}${sbindir}
21 install -m 0755 fixparts ${D}${sbindir}
22}
23
24BBCLASSEXTEND = "native nativesdk"