summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/fdisk/gptfdisk_1.0.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-08-03 19:29:50 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-10 12:40:31 -0700
commit13dce7ce4d3e38b5d1bf1eb346e35df73dc42d09 (patch)
treeacd1b83aa42d373a2c9bca088e61f8ccca95e6b8 /meta/recipes-devtools/fdisk/gptfdisk_1.0.0.bb
parent34b59db3e64c07b393cef2a128cf301683758b67 (diff)
downloadpoky-13dce7ce4d3e38b5d1bf1eb346e35df73dc42d09.tar.gz
gptfdisk: update to 1.0.0
Also, use tarballs instead of git for fetching source code. git repository does not have version tags, so upstream version check cannot be performed. (From OE-Core rev: ae2edc6912c6e234d352a11a87bf96063d09a0ee) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/fdisk/gptfdisk_1.0.0.bb')
-rw-r--r--meta/recipes-devtools/fdisk/gptfdisk_1.0.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/fdisk/gptfdisk_1.0.0.bb b/meta/recipes-devtools/fdisk/gptfdisk_1.0.0.bb
new file mode 100644
index 0000000000..f4b0e32aac
--- /dev/null
+++ b/meta/recipes-devtools/fdisk/gptfdisk_1.0.0.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "GPT fdisk is a disk partitioning tool loosely modeled on Linux fdisk, but used for modifying GUID Partition Table (GPT) disks. The related FixParts utility fixes some common problems on Master Boot Record (MBR) disks."
2
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
5
6DEPENDS = "util-linux popt ncurses"
7
8SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${PV}/${BP}.tar.gz"
9SRC_URI[md5sum] = "2061f917af084215898d4fea04d8388f"
10SRC_URI[sha256sum] = "5b66956743a799fc0471cdb032665c1391e82f9c5b3f1d7d726d29fe2ba01d6c"
11
12do_install() {
13 install -d ${D}${sbindir}
14 install -m 0755 cgdisk ${D}${sbindir}
15 install -m 0755 gdisk ${D}${sbindir}
16 install -m 0755 sgdisk ${D}${sbindir}
17 install -m 0755 fixparts ${D}${sbindir}
18}
19
20BBCLASSEXTEND = "native nativesdk"