summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/expect/expect_5.45.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-11-14 16:57:47 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-30 10:49:22 +0000
commit071afc961f49dddfb98c21c0013e7d349058e05b (patch)
tree75c4e5aef28394e81b8989228ee4b9706315d4d3 /meta/recipes-devtools/expect/expect_5.45.bb
parent356bbe757c82232cfe8505c5092464dc017cd196 (diff)
downloadpoky-071afc961f49dddfb98c21c0013e7d349058e05b.tar.gz
expect: update to 5.45.3
(From OE-Core rev: 08bd3f5a3fbd69520dfde8499b22a0fbb5977a80) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/expect/expect_5.45.bb')
-rw-r--r--meta/recipes-devtools/expect/expect_5.45.bb78
1 files changed, 0 insertions, 78 deletions
diff --git a/meta/recipes-devtools/expect/expect_5.45.bb b/meta/recipes-devtools/expect/expect_5.45.bb
deleted file mode 100644
index c9f5aba897..0000000000
--- a/meta/recipes-devtools/expect/expect_5.45.bb
+++ /dev/null
@@ -1,78 +0,0 @@
1SUMMARY = "tool for automating interactive applications according to a script"
2DESCRIPTION = "Expect is a tool for automating interactive applications according to a script. \
3Following the script, Expect knows what can be expected from a program and what \
4the correct response should be. Expect is also useful for testing these same \
5applications. And by adding Tk, you can also wrap interactive applications in \
6X11 GUIs. An interpreted language provides branching and high-level control \
7structures to direct the dialogue. In addition, the user can take control and \
8interact directly when desired, afterward returning control to the script. \
9"
10HOMEPAGE = "http://sourceforge.net/projects/expect/"
11LICENSE = "PD"
12SECTION = "devel"
13
14LIC_FILES_CHKSUM = "file://license.terms;md5=fbf2de7e9102505b1439db06fc36ce5c"
15
16DEPENDS += "tcl"
17RDEPENDS_${PN} = "tcl"
18
19inherit autotools update-alternatives
20
21PR = "r1"
22
23SRC_URI = "${SOURCEFORGE_MIRROR}/expect/Expect/${PV}/${BPN}${PV}.tar.gz \
24 file://0001-configure.in.patch \
25 file://0002-tcl.m4.patch \
26 file://01-example-shebang.patch \
27 file://0001-expect-install-scripts-without-using-the-fixline1-tc.patch \
28 file://0001-Resolve-string-formatting-issues.patch \
29 file://0001-expect-Fix-segfaults-if-Tcl-is-built-with-stubs-and-.patch \
30 "
31SRC_URI[md5sum] = "44e1a4f4c877e9ddc5a542dfa7ecc92b"
32SRC_URI[sha256sum] = "b28dca90428a3b30e650525cdc16255d76bb6ccd65d448be53e620d95d5cc040"
33
34UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/expect/files/Expect/"
35UPSTREAM_CHECK_REGEX = "/Expect/(?P<pver>(\d+[\.\-_]*)+)/"
36
37S = "${WORKDIR}/${BPN}${PV}"
38
39do_install_append() {
40 install -d ${D}${libdir}
41 install -m 0755 ${D}${libdir}/expect${PV}/libexpect*.so ${D}${libdir}/
42 install -m 0755 ${S}/fixline1 ${D}${libdir}/expect${PV}/
43 install -m 0755 ${S}/example/* ${D}${libdir}/expect${PV}/
44 rm ${D}${libdir}/expect${PV}/libexpect*.so
45 sed -e 's|$dir|${libdir}|' -i ${D}${libdir}/expect${PV}/pkgIndex.tcl
46}
47
48# Apparently the public Tcl headers are only in /usr/include/tcl8.6
49# when building for the target.
50TCL_INCLUDE_PATH = ""
51TCL_INCLUDE_PATH_class-target = "--with-tclinclude=${STAGING_INCDIR}/tcl8.6"
52
53EXTRA_OECONF += "--with-tcl=${STAGING_LIBDIR} \
54 --enable-shared \
55 --enable-threads \
56 --disable-rpath \
57 ${TCL_INCLUDE_PATH} \
58 "
59EXTRA_OEMAKE_install = " 'SCRIPTS=' "
60
61ALTERNATIVE_${PN} = "mkpasswd"
62ALTERNATIVE_LINK_NAME[mkpasswd] = "${bindir}/mkpasswd"
63# Use lower priority than busybox's mkpasswd (created when built with CONFIG_CRYPTPW)
64ALTERNATIVE_PRIORITY[mkpasswd] = "40"
65
66FILES_${PN}-dev = "${libdir_native}/expect${PV}/libexpect*.so \
67 ${includedir}/expect.h \
68 ${includedir}/expect_tcl.h \
69 ${includedir}/expect_comm.h \
70 ${includedir}/tcldbg.h \
71 ${includedir}/*.h \
72 "
73
74FILES_${PN} += "${libdir}/libexpect${PV}.so \
75 ${libdir}/expect${PV}/* \
76 "
77
78BBCLASSEXTEND = "native nativesdk"