summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/elfutils/elfutils_0.178.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-01-14 14:59:57 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-16 22:33:09 +0000
commite2848469adc841299c9067ba8183b3a7c0c20b57 (patch)
tree9f0b5576ff50d7009a5138fab3a2a2b149f8e1b1 /meta/recipes-devtools/elfutils/elfutils_0.178.bb
parent83b900fec5e07414b0f06fc1ecc11ed145cc19d5 (diff)
downloadpoky-e2848469adc841299c9067ba8183b3a7c0c20b57.tar.gz
elfutils: upgrade 0.177 -> 0.178
Remove 0007-Fix-control-path-where-we-have-str-as-uninitialized-.patch as issue fixed upstream. Rebase other patches. Adjust ptests, pass rate is now 100% again: ====================== All 206 tests passed (6 tests were not run) ====================== (From OE-Core rev: dce25738c82335f2a92b32bd52f0c63e2dbd336e) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/elfutils/elfutils_0.178.bb')
-rw-r--r--meta/recipes-devtools/elfutils/elfutils_0.178.bb160
1 files changed, 160 insertions, 0 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.178.bb b/meta/recipes-devtools/elfutils/elfutils_0.178.bb
new file mode 100644
index 0000000000..9393628dd1
--- /dev/null
+++ b/meta/recipes-devtools/elfutils/elfutils_0.178.bb
@@ -0,0 +1,160 @@
1SUMMARY = "Utilities and libraries for handling compiled object files"
2HOMEPAGE = "https://sourceware.org/elfutils"
3SECTION = "base"
4LICENSE = "GPLv2 & LGPLv3+ & GPLv3+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6DEPENDS = "zlib virtual/libintl"
7DEPENDS_append_libc-musl = " argp-standalone fts musl-obstack "
8# The Debian patches below are from:
9# http://ftp.de.debian.org/debian/pool/main/e/elfutils/elfutils_0.176-1.debian.tar.xz
10SRC_URI = "https://sourceware.org/elfutils/ftp/${PV}/${BP}.tar.bz2 \
11 file://0001-dso-link-change.patch \
12 file://0002-Fix-elf_cvt_gunhash-if-dest-and-src-are-same.patch \
13 file://0003-fixheadercheck.patch \
14 file://0004-Disable-the-test-to-convert-euc-jp.patch \
15 file://0006-Fix-build-on-aarch64-musl.patch \
16 file://0001-libasm-may-link-with-libbz2-if-found.patch \
17 file://0001-libelf-elf_end.c-check-data_list.data.d.d_buf-before.patch \
18 file://debian/hppa_backend.diff \
19 file://debian/arm_backend.diff \
20 file://debian/mips_backend.diff \
21 file://debian/mips_readelf_w.patch \
22 file://debian/kfreebsd_path.patch \
23 file://debian/0001-Ignore-differences-between-mips-machine-identifiers.patch \
24 file://debian/0002-Add-support-for-mips64-abis-in-mips_retval.c.patch \
25 file://debian/0003-Add-mips-n64-relocation-format-hack.patch \
26 file://debian/hurd_path.patch \
27 file://debian/ignore_strmerge.diff \
28 file://debian/disable_werror.patch \
29 file://debian/testsuite-ignore-elflint.diff \
30 file://debian/mips_cfi.patch \
31 file://debian/0001-fix-compile-failure-with-debian-patches.patch \
32 file://0001-skip-the-test-when-gcc-not-deployed.patch \
33 file://0001-ppc_initreg.c-Incliude-asm-ptrace.h-for-pt_regs-defi.patch \
34 file://run-ptest \
35 file://ptest.patch \
36 "
37SRC_URI_append_libc-musl = " \
38 file://0001-musl-obstack-fts.patch \
39 file://0002-musl-libs.patch \
40 file://0003-musl-utils.patch \
41 file://0004-Fix-error-on-musl.patch \
42 "
43SRC_URI[md5sum] = "5480d0b7174446aba13a6adde107287f"
44SRC_URI[sha256sum] = "31e7a00e96d4e9c4bda452e1f2cdac4daf8abd24f5e154dee232131899f3a0f2"
45
46inherit autotools gettext ptest pkgconfig
47
48EXTRA_OECONF = "--program-prefix=eu- --disable-debuginfod"
49
50DEPENDS_BZIP2 = "bzip2-replacement-native"
51DEPENDS_BZIP2_class-target = "bzip2"
52
53PACKAGECONFIG ??= ""
54PACKAGECONFIG[bzip2] = "--with-bzlib,--without-bzlib,${DEPENDS_BZIP2}"
55PACKAGECONFIG[xz] = "--with-lzma,--without-lzma,xz"
56
57RDEPENDS_${PN}-ptest += "libasm libelf bash make coreutils ${PN}-binutils"
58
59EXTRA_OECONF_append_class-target += "--disable-tests-rpath"
60
61do_install_append() {
62 if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then
63 rm -f ${D}${bindir}/eu-objdump
64 fi
65}
66
67do_compile_ptest() {
68 cd ${B}/tests
69 oe_runmake buildtest-TESTS oecheck
70}
71
72do_install_ptest() {
73 if [ ${PTEST_ENABLED} = "1" ]; then
74 # copy the files which needed by the cases
75 TEST_FILES="strip strip.o addr2line elfcmp objdump readelf size.o nm.o nm elflint elfcompress elfclassify stack unstrip"
76 install -d -m 755 ${D}${PTEST_PATH}/src
77 install -d -m 755 ${D}${PTEST_PATH}/libelf
78 install -d -m 755 ${D}${PTEST_PATH}/libdw
79 install -d -m 755 ${D}${PTEST_PATH}/libasm
80 for test_file in ${TEST_FILES}; do
81 if [ -f ${B}/src/${test_file} ]; then
82 cp -r ${B}/src/${test_file} ${D}${PTEST_PATH}/src
83 fi
84 done
85 cp ${D}${libdir}/libelf-${PV}.so ${D}${PTEST_PATH}/libelf/libelf.so
86 cp ${D}${libdir}/libdw-${PV}.so ${D}${PTEST_PATH}/libdw/libdw.so
87 cp ${D}${libdir}/libasm-${PV}.so ${D}${PTEST_PATH}/libasm/libasm.so
88 cp -r ${S}/tests/ ${D}${PTEST_PATH}
89 cp -r ${B}/tests/* ${D}${PTEST_PATH}/tests
90 cp -r ${B}/config.h ${D}${PTEST_PATH}
91 cp -r ${B}/backends ${D}${PTEST_PATH}
92 sed -i '/^Makefile:/c Makefile:' ${D}${PTEST_PATH}/tests/Makefile
93 find ${D}${PTEST_PATH} -type f -name *.[hoc] | xargs -i rm {}
94 fi
95}
96
97EXTRA_OEMAKE_class-native = ""
98EXTRA_OEMAKE_class-nativesdk = ""
99
100BBCLASSEXTEND = "native nativesdk"
101
102# Package utilities separately
103PACKAGES =+ "${PN}-binutils libelf libasm libdw"
104
105# shared libraries are licensed GPLv2 or GPLv3+, binaries GPLv3+
106# according to NEWS file:
107# "The license is now GPLv2/LGPLv3+ for the libraries and GPLv3+ for stand-alone
108# programs. There is now also a formal CONTRIBUTING document describing how to
109# submit patches."
110LICENSE_${PN}-binutils = "GPLv3+"
111LICENSE_${PN} = "GPLv3+"
112LICENSE_libelf = "GPLv2 | LGPLv3+"
113LICENSE_libasm = "GPLv2 | LGPLv3+"
114LICENSE_libdw = "GPLv2 | LGPLv3+"
115
116FILES_${PN}-binutils = "\
117 ${bindir}/eu-addr2line \
118 ${bindir}/eu-ld \
119 ${bindir}/eu-nm \
120 ${bindir}/eu-readelf \
121 ${bindir}/eu-size \
122 ${bindir}/eu-strip"
123
124FILES_libelf = "${libdir}/libelf-${PV}.so ${libdir}/libelf.so.*"
125FILES_libasm = "${libdir}/libasm-${PV}.so ${libdir}/libasm.so.*"
126FILES_libdw = "${libdir}/libdw-${PV}.so ${libdir}/libdw.so.* ${libdir}/elfutils/lib*"
127# Some packages have the version preceeding the .so instead properly
128# versioned .so.<version>, so we need to reorder and repackage.
129#FILES_${PN} += "${libdir}/*-${PV}.so ${base_libdir}/*-${PV}.so"
130#FILES_SOLIBSDEV = "${libdir}/libasm.so ${libdir}/libdw.so ${libdir}/libelf.so"
131
132# The package contains symlinks that trip up insane
133INSANE_SKIP_${MLPREFIX}libdw = "dev-so"
134
135# avoid stripping some generated binaries otherwise some of the tests such as test-nlist,
136# run-strip-reloc.sh, run-strip-strmerge.sh and so on will fail
137INHIBIT_PACKAGE_STRIP_FILES = "\
138 ${PKGD}${PTEST_PATH}/tests/test-nlist \
139 ${PKGD}${PTEST_PATH}/tests/elfstrmerge \
140 ${PKGD}${PTEST_PATH}/tests/backtrace-child \
141 ${PKGD}${PTEST_PATH}/tests/backtrace-data \
142 ${PKGD}${PTEST_PATH}/tests/deleted \
143 ${PKGD}${PTEST_PATH}/src/strip \
144 ${PKGD}${PTEST_PATH}/src/addr2line \
145 ${PKGD}${PTEST_PATH}/src/elfcmp \
146 ${PKGD}${PTEST_PATH}/src/objdump \
147 ${PKGD}${PTEST_PATH}/src/readelf \
148 ${PKGD}${PTEST_PATH}/src/nm \
149 ${PKGD}${PTEST_PATH}/src/elflint \
150 ${PKGD}${PTEST_PATH}/src/elfclassify \
151 ${PKGD}${PTEST_PATH}/src/stack \
152 ${PKGD}${PTEST_PATH}/src/unstrip \
153 ${PKGD}${PTEST_PATH}/libelf/libelf.so \
154 ${PKGD}${PTEST_PATH}/libdw/libdw.so \
155 ${PKGD}${PTEST_PATH}/libasm/libasm.so \
156 ${PKGD}${PTEST_PATH}/backends/libebl_i386.so \
157 ${PKGD}${PTEST_PATH}/backends/libebl_x86_64.so \
158"
159
160PRIVATE_LIBS_${PN}-ptest = "libdw.so.1 libelf.so.1 libasm.so.1"