summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/elfutils/elfutils_0.164.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-12-26 20:01:44 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-30 11:36:58 +0000
commitdf95988e1ea3d582e687c39a361728f88c419bca (patch)
treeee6c6a75f45b4803945fc9b244c3e25bf58ac8a0 /meta/recipes-devtools/elfutils/elfutils_0.164.bb
parent047ad2c81a7ec0d59d5fb1ddf52668c29a1119c9 (diff)
downloadpoky-df95988e1ea3d582e687c39a361728f88c419bca.tar.gz
elfutils: Fix build with uclibc/musl
Remove mempcpy patch its already in uclibc now refresh libargp patch to match latest elfutils Add ALLOW_EMPTY for musl core-image-cmdline-full asks for elfutils package to be added to package it has all eu-* tools but we dont build them on musl. nevertheless lets satisfy the dependency so image can build for musl Build libdw,libasm,libebl along with libelf enhance the musl portability patch to compile every other library except the eu-* tools Fix build on aarch64/musl issues Header inclusion ends up with duplicate definitions of iovec struct since uclibc defines the same in usersapce, we have been depending upong including the kernel header on aarch64, using sys/uio.h is the right approach Fix x86 build warning seen on musl (From OE-Core rev: a28c70455931e0b7e3449a76c3b9132bd572478b) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/elfutils/elfutils_0.164.bb')
-rw-r--r--meta/recipes-devtools/elfutils/elfutils_0.164.bb13
1 files changed, 8 insertions, 5 deletions
diff --git a/meta/recipes-devtools/elfutils/elfutils_0.164.bb b/meta/recipes-devtools/elfutils/elfutils_0.164.bb
index c27635dda3..4964c05078 100644
--- a/meta/recipes-devtools/elfutils/elfutils_0.164.bb
+++ b/meta/recipes-devtools/elfutils/elfutils_0.164.bb
@@ -4,6 +4,7 @@ SECTION = "base"
4LICENSE = "(GPLv3 & Elfutils-Exception)" 4LICENSE = "(GPLv3 & Elfutils-Exception)"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" 5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6DEPENDS = "libtool bzip2 zlib virtual/libintl" 6DEPENDS = "libtool bzip2 zlib virtual/libintl"
7DEPENDS_append_libc-musl = " argp-standalone fts "
7 8
8SRC_URI = "https://fedorahosted.org/releases/e/l/elfutils/${PV}/${BP}.tar.bz2" 9SRC_URI = "https://fedorahosted.org/releases/e/l/elfutils/${PV}/${BP}.tar.bz2"
9 10
@@ -11,13 +12,14 @@ SRC_URI[md5sum] = "2e4536c1c48034f188a80789a59114d8"
11SRC_URI[sha256sum] = "9683c025928a12d06b7fe812928aa6235249e22d197d086f7084606a48165900" 12SRC_URI[sha256sum] = "9683c025928a12d06b7fe812928aa6235249e22d197d086f7084606a48165900"
12 13
13SRC_URI += "\ 14SRC_URI += "\
14 file://mempcpy.patch \
15 file://dso-link-change.patch \ 15 file://dso-link-change.patch \
16 file://Fix_elf_cvt_gunhash.patch \ 16 file://Fix_elf_cvt_gunhash.patch \
17 file://fixheadercheck.patch \ 17 file://fixheadercheck.patch \
18 file://0001-elf_getarsym-Silence-Werror-maybe-uninitialized-fals.patch \ 18 file://0001-elf_getarsym-Silence-Werror-maybe-uninitialized-fals.patch \
19 file://0001-remove-the-unneed-checking.patch \ 19 file://0001-remove-the-unneed-checking.patch \
20 file://0001-fix-a-stack-usage-warning.patch \ 20 file://0001-fix-a-stack-usage-warning.patch \
21 file://aarch64_uio.patch \
22 file://shadow.patch \
21" 23"
22 24
23# pick the patch from debian 25# pick the patch from debian
@@ -33,10 +35,9 @@ SRC_URI += "\
33 file://0001-Ignore-differences-between-mips-machine-identifiers.patch \ 35 file://0001-Ignore-differences-between-mips-machine-identifiers.patch \
34 file://0002-Add-support-for-mips64-abis-in-mips_retval.c.patch \ 36 file://0002-Add-support-for-mips64-abis-in-mips_retval.c.patch \
35 file://0003-Add-mips-n64-relocation-format-hack.patch \ 37 file://0003-Add-mips-n64-relocation-format-hack.patch \
38 file://uclibc-support.patch \
36" 39"
37 40SRC_URI_append_libc-musl = " file://0001-build-Provide-alternatives-for-glibc-assumptions-hel.patch "
38# Only apply when building uclibc based target recipe
39SRC_URI_append_libc-uclibc = " file://uclibc-support-for-elfutils-0.161.patch"
40 41
41# The buildsystem wants to generate 2 .h files from source using a binary it just built, 42# The buildsystem wants to generate 2 .h files from source using a binary it just built,
42# which can not pass the cross compiling, so let's work around it by adding 2 .h files 43# which can not pass the cross compiling, so let's work around it by adding 2 .h files
@@ -50,7 +51,7 @@ EXTRA_OECONF_append_libc-uclibc = " --enable-uclibc"
50 51
51do_install_append() { 52do_install_append() {
52 if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then 53 if [ "${TARGET_ARCH}" != "x86_64" ] && [ -z `echo "${TARGET_ARCH}"|grep 'i.86'` ];then
53 rm ${D}${bindir}/eu-objdump 54 rm -f ${D}${bindir}/eu-objdump
54 fi 55 fi
55} 56}
56 57
@@ -62,6 +63,8 @@ EXTRA_OEMAKE_libc-uclibc = "-C libelf"
62EXTRA_OEMAKE_class-native = "" 63EXTRA_OEMAKE_class-native = ""
63EXTRA_OEMAKE_class-nativesdk = "" 64EXTRA_OEMAKE_class-nativesdk = ""
64 65
66ALLOW_EMPTY_${PN}_libc-musl = "1"
67
65BBCLASSEXTEND = "native nativesdk" 68BBCLASSEXTEND = "native nativesdk"
66 69
67# Package utilities separately 70# Package utilities separately