summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/e2fsprogs/e2fsprogs_git.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-01-13 17:37:28 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-18 11:47:03 +0000
commit8c3276ecea38d4d67c22e6db49060b2d4b457278 (patch)
treea08abeadef1a30dff799b50755a33a4faf8ab33c /meta/recipes-devtools/e2fsprogs/e2fsprogs_git.bb
parentb248e55c0c39a4d45adc0690f2eefb332ab233f5 (diff)
downloadpoky-8c3276ecea38d4d67c22e6db49060b2d4b457278.tar.gz
e2fsprogs: 1.42.9 -> 1.43 (master)
Upgrade to 1.43 (master) to make "mke2fs -d" support xattr, so that the layer which requires xattr such as meta-selinux can populate images easily. * Remove the following patches since they are alredy in the source. 0001-e2fsprogs-fix-cross-compilation-problem.patch 0001-libext2fs-fix-potential-buffer-overflow-in-closefs.patch 0001-mke2fs-add-the-ability-to-copy-files-from-a-given-di.patch 0002-misc-create_inode.c-copy-files-recursively.patch 0003-misc-create_inode.c-create-special-file.patch 0004-misc-create_inode.c-create-symlink.patch 0005-misc-create_inode.c-copy-regular-file.patch 0006-misc-create_inode.c-create-directory.patch 0007-misc-create_inode.c-set-owner-mode-time-for-the-inod.patch 0008-mke2fs.c-add-an-option-d-root-directory.patch 0009-misc-create_inode.c-handle-hardlinks.patch 0010-debugfs-use-the-functions-in-misc-create_inode.c.patch 0011-mke2fs.8.in-update-the-manual-for-the-d-option.patch 0012-Fix-musl-build-failures.patch CVE-2015-0247.patch copy-in-create-hardlinks-with-the-correct-directory-.patch fix-icache.patch misc-mke2fs.c-return-error-when-failed-to-populate-fs.patch * Remove cache_inode.patch since it is not needed any more * Updated mkdir.patch and ptest.patch * Add --enable-libblkid to EXTRA_OECONF since libblkid is not created by default. * Time of core-image-sato-sdk do_rootfs: - Before upgrade real 3m18.508s user 7m42.088s sys 1m1.984s - After upgrade real 3m21.552s user 7m38.496s sys 1m0.644s The are nearly the same * The "fsck -f" shows the image is OK, and also can boot. [YOCTO #8622] (From OE-Core rev: a1f235ad736d322bb50eb4a4293b6b2f4e5200aa) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/e2fsprogs/e2fsprogs_git.bb')
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs_git.bb93
1 files changed, 93 insertions, 0 deletions
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs_git.bb b/meta/recipes-devtools/e2fsprogs/e2fsprogs_git.bb
new file mode 100644
index 0000000000..0aab8ae3f6
--- /dev/null
+++ b/meta/recipes-devtools/e2fsprogs/e2fsprogs_git.bb
@@ -0,0 +1,93 @@
1require e2fsprogs.inc
2
3SRC_URI += "file://acinclude.m4 \
4 file://remove.ldconfig.call.patch \
5 file://quiet-debugfs.patch \
6 file://run-ptest \
7 file://ptest.patch \
8 file://mkdir.patch \
9"
10
11SRCREV = "0f26747167cc9d82df849b0aad387bf824f04544"
12PV = "1.42+1.43-git${SRCPV}"
13
14EXTRA_OECONF += "--libdir=${base_libdir} --sbindir=${base_sbindir} \
15 --enable-elf-shlibs --disable-libuuid --disable-uuidd \
16 --enable-libblkid --enable-verbose-makecmds"
17
18EXTRA_OECONF_darwin = "--libdir=${base_libdir} --sbindir=${base_sbindir} --enable-bsd-shlibs"
19
20do_configure_prepend () {
21 cp ${WORKDIR}/acinclude.m4 ${S}/
22}
23
24do_install () {
25 oe_runmake 'DESTDIR=${D}' install
26 oe_runmake 'DESTDIR=${D}' install-libs
27 # We use blkid from util-linux now so remove from here
28 rm -f ${D}${base_libdir}/libblkid*
29 rm -rf ${D}${includedir}/blkid
30 rm -f ${D}${base_libdir}/pkgconfig/blkid.pc
31 rm -f ${D}${base_sbindir}/blkid
32 rm -f ${D}${base_sbindir}/fsck
33 rm -f ${D}${base_sbindir}/findfs
34
35 # e2initrd_helper and the pkgconfig files belong in libdir
36 if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then
37 install -d ${D}${libdir}
38 mv ${D}${base_libdir}/e2initrd_helper ${D}${libdir}
39 mv ${D}${base_libdir}/pkgconfig ${D}${libdir}
40 fi
41
42 oe_multilib_header ext2fs/ext2_types.h
43 install -d ${D}${base_bindir}
44 mv ${D}${bindir}/chattr ${D}${base_bindir}/chattr.e2fsprogs
45
46 install -v -m 755 ${S}/contrib/populate-extfs.sh ${D}${base_sbindir}/
47}
48
49do_install_append_class-target() {
50 # Clean host path in compile_et, mk_cmds
51 sed -i -e "s,ET_DIR=\"${S}/lib/et\",ET_DIR=\"${datadir}/et\",g" ${D}${bindir}/compile_et
52 sed -i -e "s,SS_DIR=\"${S}/lib/ss\",SS_DIR=\"${datadir}/ss\",g" ${D}${bindir}/mk_cmds
53}
54
55RDEPENDS_e2fsprogs = "e2fsprogs-badblocks"
56RRECOMMENDS_e2fsprogs = "e2fsprogs-mke2fs e2fsprogs-e2fsck"
57
58PACKAGES =+ "e2fsprogs-e2fsck e2fsprogs-mke2fs e2fsprogs-tune2fs e2fsprogs-badblocks e2fsprogs-resize2fs"
59PACKAGES =+ "libcomerr libss libe2p libext2fs"
60
61FILES_e2fsprogs-resize2fs = "${base_sbindir}/resize2fs*"
62FILES_e2fsprogs-e2fsck = "${base_sbindir}/e2fsck ${base_sbindir}/fsck.ext*"
63FILES_e2fsprogs-mke2fs = "${base_sbindir}/mke2fs ${base_sbindir}/mkfs.ext* ${sysconfdir}/mke2fs.conf"
64FILES_e2fsprogs-tune2fs = "${base_sbindir}/tune2fs ${base_sbindir}/e2label"
65FILES_e2fsprogs-badblocks = "${base_sbindir}/badblocks"
66FILES_libcomerr = "${base_libdir}/libcom_err.so.*"
67FILES_libss = "${base_libdir}/libss.so.*"
68FILES_libe2p = "${base_libdir}/libe2p.so.*"
69FILES_libext2fs = "${libdir}/e2initrd_helper ${base_libdir}/libext2fs.so.*"
70FILES_${PN}-dev += "${datadir}/*/*.awk ${datadir}/*/*.sed ${base_libdir}/*.so"
71
72ALTERNATIVE_${PN} = "chattr"
73ALTERNATIVE_PRIORITY = "100"
74ALTERNATIVE_LINK_NAME[chattr] = "${base_bindir}/chattr"
75ALTERNATIVE_TARGET[chattr] = "${base_bindir}/chattr.e2fsprogs"
76
77ALTERNATIVE_${PN}-doc = "libblkid.3 blkid.8 findfs.8 fsck.8"
78ALTERNATIVE_LINK_NAME[libblkid.3] = "${mandir}/man3/libblkid.3"
79ALTERNATIVE_LINK_NAME[blkid.8] = "${mandir}/man8/blkid.8"
80ALTERNATIVE_LINK_NAME[findfs.8] = "${mandir}/man8/findfs.8"
81ALTERNATIVE_LINK_NAME[fsck.8] = "${mandir}/man8/fsck.8"
82
83RDEPENDS_${PN}-ptest += "${PN} ${PN}-tune2fs coreutils procps bash"
84
85do_compile_ptest() {
86 oe_runmake -C ${B}/tests
87}
88
89do_install_ptest() {
90 cp -a ${B}/tests ${D}${PTEST_PATH}/test
91 cp -a ${S}/tests/* ${D}${PTEST_PATH}/test
92 sed -e 's!../e2fsck/e2fsck!e2fsck!g' -i ${D}${PTEST_PATH}/test/*/expect*
93}