summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.9.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-01-01 01:25:17 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-06 11:13:57 +0000
commit63281708fab30adc4ca1a506deefbf8a54dcce6d (patch)
treebf6b9b48314909bd062f4fba473708065cbd6c81 /meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.9.bb
parent5ddb7d4ebb135e288ab56b44aceabb3578ae9ed1 (diff)
downloadpoky-63281708fab30adc4ca1a506deefbf8a54dcce6d.tar.gz
e2fsprogs: upgrade to 1.42.9
* Upgrade to 1.42.9 * Remove the following patches since they have been merged/fixed by upstream: - debugfs-extent-header.patch - debugfs-sparse-copy.patch - debugfs-too-short.patch - e2fsprogs-fix-tests-f_extent_oobounds.patch - fallocate.patch * The populate-extfs.sh had been merged by the upstream, but I'd like to go on using the previous one which is from our meta layer, they are a little different, and the script would be dropped when we use the mke2fs to populate the rootfs. * Sumitted the patch for populate-extfs.sh (from Søren Holm) to upstream. * Submitted fix-icache.patch to upstream, I wrongly thought it was not applicable to the upstream, but it does. * Join the do_install() and do_install_append() together. (From OE-Core rev: 82cc941128f9eaf57c3a9a648fc58227f6c1956c) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.9.bb')
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.9.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.9.bb b/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.9.bb
new file mode 100644
index 0000000000..0c8ec717f5
--- /dev/null
+++ b/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.9.bb
@@ -0,0 +1,61 @@
1require e2fsprogs.inc
2
3
4SRC_URI += "file://acinclude.m4 \
5 file://remove.ldconfig.call.patch \
6 file://fix-icache.patch \
7 file://populate-extfs.sh \
8 file://quiet-debugfs.patch \
9"
10
11SRC_URI[md5sum] = "3f8e41e63b432ba114b33f58674563f7"
12SRC_URI[sha256sum] = "2f92ac06e92fa00f2ada3ee67dad012d74d685537527ad1241d82f2d041f2802"
13
14EXTRA_OECONF += "--libdir=${base_libdir} --sbindir=${base_sbindir} --enable-elf-shlibs --disable-libuuid --disable-uuidd"
15EXTRA_OECONF_darwin = "--libdir=${base_libdir} --sbindir=${base_sbindir} --enable-bsd-shlibs"
16
17do_configure_prepend () {
18 cp ${WORKDIR}/acinclude.m4 ${S}/
19}
20
21do_compile_prepend () {
22 find ./ -print | grep -v ./patches | xargs chmod u=rwX
23 ( cd ${S}/util; ${BUILD_CC} subst.c -o ${B}/util/subst )
24}
25
26do_install () {
27 oe_runmake 'DESTDIR=${D}' install
28 oe_runmake 'DESTDIR=${D}' install-libs
29 # We use blkid from util-linux now so remove from here
30 rm -f ${D}${base_libdir}/libblkid*
31 rm -rf ${D}${includedir}/blkid
32 rm -f ${D}${base_libdir}/pkgconfig/blkid.pc
33 rm -f ${D}${base_sbindir}/blkid
34 rm -f ${D}${base_sbindir}/fsck
35 rm -f ${D}${base_sbindir}/findfs
36
37 # e2initrd_helper and the pkgconfig files belong in libdir
38 if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then
39 install -d ${D}${libdir}
40 mv ${D}${base_libdir}/e2initrd_helper ${D}${libdir}
41 mv ${D}${base_libdir}/pkgconfig ${D}${libdir}
42 fi
43 install -m 0755 ${WORKDIR}/populate-extfs.sh ${D}${bindir}
44}
45
46RDEPENDS_e2fsprogs = "e2fsprogs-badblocks"
47
48PACKAGES =+ "e2fsprogs-e2fsck e2fsprogs-mke2fs e2fsprogs-tune2fs e2fsprogs-badblocks"
49PACKAGES =+ "libcomerr libss libe2p libext2fs"
50
51FILES_e2fsprogs-e2fsck = "${base_sbindir}/e2fsck ${base_sbindir}/fsck.ext*"
52FILES_e2fsprogs-mke2fs = "${base_sbindir}/mke2fs ${base_sbindir}/mkfs.ext* ${sysconfdir}/mke2fs.conf"
53FILES_e2fsprogs-tune2fs = "${base_sbindir}/tune2fs ${base_sbindir}/e2label"
54FILES_e2fsprogs-badblocks = "${base_sbindir}/badblocks"
55FILES_libcomerr = "${base_libdir}/libcom_err.so.*"
56FILES_libss = "${base_libdir}/libss.so.*"
57FILES_libe2p = "${base_libdir}/libe2p.so.*"
58FILES_libext2fs = "${libdir}/e2initrd_helper ${base_libdir}/libext2fs.so.*"
59FILES_${PN}-dev += "${datadir}/*/*.awk ${datadir}/*/*.sed ${base_libdir}/*.so"
60
61BBCLASSEXTEND = "native"