summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.8.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-01-01 01:25:17 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-06 11:13:57 +0000
commit63281708fab30adc4ca1a506deefbf8a54dcce6d (patch)
treebf6b9b48314909bd062f4fba473708065cbd6c81 /meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.8.bb
parent5ddb7d4ebb135e288ab56b44aceabb3578ae9ed1 (diff)
downloadpoky-63281708fab30adc4ca1a506deefbf8a54dcce6d.tar.gz
e2fsprogs: upgrade to 1.42.9
* Upgrade to 1.42.9 * Remove the following patches since they have been merged/fixed by upstream: - debugfs-extent-header.patch - debugfs-sparse-copy.patch - debugfs-too-short.patch - e2fsprogs-fix-tests-f_extent_oobounds.patch - fallocate.patch * The populate-extfs.sh had been merged by the upstream, but I'd like to go on using the previous one which is from our meta layer, they are a little different, and the script would be dropped when we use the mke2fs to populate the rootfs. * Sumitted the patch for populate-extfs.sh (from Søren Holm) to upstream. * Submitted fix-icache.patch to upstream, I wrongly thought it was not applicable to the upstream, but it does. * Join the do_install() and do_install_append() together. (From OE-Core rev: 82cc941128f9eaf57c3a9a648fc58227f6c1956c) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.8.bb')
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.8.bb67
1 files changed, 0 insertions, 67 deletions
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.8.bb b/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.8.bb
deleted file mode 100644
index 6175ce7281..0000000000
--- a/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.42.8.bb
+++ /dev/null
@@ -1,67 +0,0 @@
1require e2fsprogs.inc
2
3
4SRC_URI += "file://acinclude.m4 \
5 file://remove.ldconfig.call.patch \
6 file://debugfs-too-short.patch \
7 file://debugfs-sparse-copy.patch \
8 file://fix-icache.patch \
9 file://debugfs-extent-header.patch \
10 file://populate-extfs.sh \
11 file://e2fsprogs-fix-tests-f_extent_oobounds.patch \
12 file://quiet-debugfs.patch \
13"
14
15SRC_URI[md5sum] = "8ef664b6eb698aa6b733df59b17b9ed4"
16SRC_URI[sha256sum] = "b984aaf1fe888d6a4cf8c2e8d397207879599b5368f1d33232c1ec9d68d00c97"
17
18EXTRA_OECONF += "--libdir=${base_libdir} --sbindir=${base_sbindir} --enable-elf-shlibs --disable-libuuid --disable-uuidd"
19EXTRA_OECONF_darwin = "--libdir=${base_libdir} --sbindir=${base_sbindir} --enable-bsd-shlibs"
20
21do_configure_prepend () {
22 cp ${WORKDIR}/acinclude.m4 ${S}/
23}
24
25do_compile_prepend () {
26 find ./ -print | grep -v ./patches | xargs chmod u=rwX
27 ( cd ${S}/util; ${BUILD_CC} subst.c -o ${B}/util/subst )
28}
29
30do_install () {
31 oe_runmake 'DESTDIR=${D}' install
32 oe_runmake 'DESTDIR=${D}' install-libs
33 # We use blkid from util-linux now so remove from here
34 rm -f ${D}${base_libdir}/libblkid*
35 rm -rf ${D}${includedir}/blkid
36 rm -f ${D}${base_libdir}/pkgconfig/blkid.pc
37 rm -f ${D}${base_sbindir}/blkid
38 rm -f ${D}${base_sbindir}/fsck
39 rm -f ${D}${base_sbindir}/findfs
40}
41
42do_install_append () {
43 # e2initrd_helper and the pkgconfig files belong in libdir
44 if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then
45 install -d ${D}${libdir}
46 mv ${D}${base_libdir}/e2initrd_helper ${D}${libdir}
47 mv ${D}${base_libdir}/pkgconfig ${D}${libdir}
48 fi
49 install -m 0755 ${WORKDIR}/populate-extfs.sh ${D}${bindir}
50}
51
52RDEPENDS_e2fsprogs = "e2fsprogs-badblocks"
53
54PACKAGES =+ "e2fsprogs-e2fsck e2fsprogs-mke2fs e2fsprogs-tune2fs e2fsprogs-badblocks"
55PACKAGES =+ "libcomerr libss libe2p libext2fs"
56
57FILES_e2fsprogs-e2fsck = "${base_sbindir}/e2fsck ${base_sbindir}/fsck.ext*"
58FILES_e2fsprogs-mke2fs = "${base_sbindir}/mke2fs ${base_sbindir}/mkfs.ext* ${sysconfdir}/mke2fs.conf"
59FILES_e2fsprogs-tune2fs = "${base_sbindir}/tune2fs ${base_sbindir}/e2label"
60FILES_e2fsprogs-badblocks = "${base_sbindir}/badblocks"
61FILES_libcomerr = "${base_libdir}/libcom_err.so.*"
62FILES_libss = "${base_libdir}/libss.so.*"
63FILES_libe2p = "${base_libdir}/libe2p.so.*"
64FILES_libext2fs = "${libdir}/e2initrd_helper ${base_libdir}/libext2fs.so.*"
65FILES_${PN}-dev += "${datadir}/*/*.awk ${datadir}/*/*.sed ${base_libdir}/*.so"
66
67BBCLASSEXTEND = "native"