summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/dnf/dnf_4.5.2.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-12-26 10:26:49 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-30 14:01:06 +0000
commit86dd300de9d098e8858743c14a05c21df2786b3a (patch)
tree1b1e03afc7659e54d8038bca92a5c5a71254fbc9 /meta/recipes-devtools/dnf/dnf_4.5.2.bb
parentb24831ee762491931a110d8d432f5b65b0096d7d (diff)
downloadpoky-86dd300de9d098e8858743c14a05c21df2786b3a.tar.gz
dnf: upgrade 4.4.0 -> 4.5.2
(From OE-Core rev: f21490a872d8d3f74df7b6b788a1911014fcb32c) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/dnf/dnf_4.5.2.bb')
-rw-r--r--meta/recipes-devtools/dnf/dnf_4.5.2.bb90
1 files changed, 90 insertions, 0 deletions
diff --git a/meta/recipes-devtools/dnf/dnf_4.5.2.bb b/meta/recipes-devtools/dnf/dnf_4.5.2.bb
new file mode 100644
index 0000000000..e1b0e1a132
--- /dev/null
+++ b/meta/recipes-devtools/dnf/dnf_4.5.2.bb
@@ -0,0 +1,90 @@
1SUMMARY = "Package manager forked from Yum, using libsolv as a dependency resolver"
2DESCRIPTION = "Software package manager that installs, updates, and removes \
3packages on RPM-based Linux distributions. It automatically computes \
4dependencies and determines the actions required to install packages."
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://PACKAGE-LICENSING;md5=4a0548e303dbc77f067335b4d688e745 \
8 "
9
10SRC_URI = "git://github.com/rpm-software-management/dnf.git \
11 file://0001-Corretly-install-tmpfiles.d-configuration.patch \
12 file://0001-Do-not-hardcode-etc-and-systemd-unit-directories.patch \
13 file://0005-Do-not-prepend-installroot-to-logdir.patch \
14 file://0029-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
15 file://0030-Run-python-scripts-using-env.patch \
16 file://0001-set-python-path-for-completion_helper.patch \
17 file://0001-dnf-write-the-log-lock-to-root.patch \
18 "
19
20SRCREV = "36a3ffaee4db76a7efe7d40f4e42ce679b6a6920"
21UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
22
23S = "${WORKDIR}/git"
24
25inherit cmake gettext bash-completion distutils3-base systemd
26
27DEPENDS += "libdnf librepo libcomps python3-iniparse"
28
29# manpages generation requires http://www.sphinx-doc.org/
30EXTRA_OECMAKE = " -DWITH_MAN=0 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
31
32BBCLASSEXTEND = "native nativesdk"
33
34RDEPENDS_${PN} += " \
35 python3-core \
36 python3-codecs \
37 python3-netclient \
38 python3-email \
39 python3-threading \
40 python3-distutils \
41 python3-logging \
42 python3-fcntl \
43 librepo \
44 python3-shell \
45 libcomps \
46 libdnf \
47 python3-sqlite3 \
48 python3-compression \
49 python3-rpm \
50 python3-iniparse \
51 python3-json \
52 python3-curses \
53 python3-misc \
54 python3-gpg \
55 "
56
57RDEPENDS_${PN}_class-native = ""
58
59RRECOMMENDS_${PN}_class-target += "gnupg"
60
61# Create a symlink called 'dnf' as 'make install' does not do it, but
62# .spec file in dnf source tree does (and then Fedora and dnf documentation
63# says that dnf binary is plain 'dnf').
64do_install_append() {
65 lnr ${D}/${bindir}/dnf-3 ${D}/${bindir}/dnf
66 lnr ${D}/${bindir}/dnf-automatic-3 ${D}/${bindir}/dnf-automatic
67}
68
69# Direct dnf-native to read rpm configuration from our sysroot, not the one it was compiled in
70do_install_append_class-native() {
71 create_wrapper ${D}/${bindir}/dnf \
72 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
73 RPM_NO_CHROOT_FOR_SCRIPTS=1
74}
75
76do_install_append_class-nativesdk() {
77 create_wrapper ${D}/${bindir}/dnf \
78 RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm \
79 RPM_NO_CHROOT_FOR_SCRIPTS=1
80}
81
82SYSTEMD_SERVICE_${PN} = "dnf-makecache.service dnf-makecache.timer \
83 dnf-automatic.service dnf-automatic.timer \
84 dnf-automatic-download.service dnf-automatic-download.timer \
85 dnf-automatic-install.service dnf-automatic-install.timer \
86 dnf-automatic-notifyonly.service dnf-automatic-notifyonly.timer \
87"
88SYSTEMD_AUTO_ENABLE ?= "disable"
89
90PNBLACKLIST[dnf] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'does not build without package_rpm in PACKAGE_CLASSES due disabled rpm support in libsolv', d)}"