summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/dnf/dnf_4.2.2.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-04-25 19:28:03 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-05-02 09:08:52 +0100
commit4d8df76f401c7dde7dcb851e2536c7c00eb155eb (patch)
tree176ca3cdd0277e716f04c37850693dfb61414c1b /meta/recipes-devtools/dnf/dnf_4.2.2.bb
parent7add0b8b4db11309f59cbea4490e0e0549951f86 (diff)
downloadpoky-4d8df76f401c7dde7dcb851e2536c7c00eb155eb.tar.gz
dnf: upgrade 4.2.2 -> 4.2.21
Drop upstreamed patches. (From OE-Core rev: 7828bf903001413cb38d34f4a2525f718380b88f) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/dnf/dnf_4.2.2.bb')
-rw-r--r--meta/recipes-devtools/dnf/dnf_4.2.2.bb90
1 files changed, 0 insertions, 90 deletions
diff --git a/meta/recipes-devtools/dnf/dnf_4.2.2.bb b/meta/recipes-devtools/dnf/dnf_4.2.2.bb
deleted file mode 100644
index a046ffc05d..0000000000
--- a/meta/recipes-devtools/dnf/dnf_4.2.2.bb
+++ /dev/null
@@ -1,90 +0,0 @@
1SUMMARY = "Package manager forked from Yum, using libsolv as a dependency resolver"
2DESCRIPTION = "Software package manager that installs, updates, and removes \
3packages on RPM-based Linux distributions. It automatically computes \
4dependencies and determines the actions required to install packages."
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://PACKAGE-LICENSING;md5=4a0548e303dbc77f067335b4d688e745 \
8 "
9
10SRC_URI = "git://github.com/rpm-software-management/dnf.git \
11 file://0001-Corretly-install-tmpfiles.d-configuration.patch \
12 file://0001-Do-not-hardcode-etc-and-systemd-unit-directories.patch \
13 file://0005-Do-not-prepend-installroot-to-logdir.patch \
14 file://0029-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
15 file://0030-Run-python-scripts-using-env.patch \
16 file://Fix-SyntaxWarning.patch \
17 file://0001-set-python-path-for-completion_helper.patch \
18 "
19
20SRCREV = "9947306a55271b8b7c9e2b6e3b7d582885b6045d"
21UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
22
23S = "${WORKDIR}/git"
24
25inherit cmake gettext bash-completion distutils3-base systemd
26
27DEPENDS += "libdnf librepo libcomps python3-iniparse"
28
29# manpages generation requires http://www.sphinx-doc.org/
30EXTRA_OECMAKE = " -DWITH_MAN=0 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
31
32BBCLASSEXTEND = "native nativesdk"
33
34RDEPENDS_${PN} += " \
35 python3-core \
36 python3-codecs \
37 python3-netclient \
38 python3-email \
39 python3-threading \
40 python3-distutils \
41 python3-logging \
42 python3-fcntl \
43 librepo \
44 python3-shell \
45 libcomps \
46 libdnf \
47 python3-sqlite3 \
48 python3-compression \
49 python3-rpm \
50 python3-iniparse \
51 python3-json \
52 python3-curses \
53 python3-misc \
54 python3-gpg \
55 "
56
57RDEPENDS_${PN}_class-native = ""
58
59RRECOMMENDS_${PN}_class-target += "gnupg"
60
61# Create a symlink called 'dnf' as 'make install' does not do it, but
62# .spec file in dnf source tree does (and then Fedora and dnf documentation
63# says that dnf binary is plain 'dnf').
64do_install_append() {
65 lnr ${D}/${bindir}/dnf-3 ${D}/${bindir}/dnf
66 lnr ${D}/${bindir}/dnf-automatic-3 ${D}/${bindir}/dnf-automatic
67}
68
69# Direct dnf-native to read rpm configuration from our sysroot, not the one it was compiled in
70do_install_append_class-native() {
71 create_wrapper ${D}/${bindir}/dnf \
72 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
73 RPM_NO_CHROOT_FOR_SCRIPTS=1
74}
75
76do_install_append_class-nativesdk() {
77 create_wrapper ${D}/${bindir}/dnf \
78 RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm \
79 RPM_NO_CHROOT_FOR_SCRIPTS=1
80}
81
82SYSTEMD_SERVICE_${PN} = "dnf-makecache.service dnf-makecache.timer \
83 dnf-automatic.service dnf-automatic.timer \
84 dnf-automatic-download.service dnf-automatic-download.timer \
85 dnf-automatic-install.service dnf-automatic-install.timer \
86 dnf-automatic-notifyonly.service dnf-automatic-notifyonly.timer \
87"
88SYSTEMD_AUTO_ENABLE ?= "disable"
89
90PNBLACKLIST[dnf] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'does not build without package_rpm in PACKAGE_CLASSES due disabled rpm support in libsolv', d)}"