summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/dnf/dnf_2.6.3.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-08-07 14:44:58 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-13 09:27:37 +0100
commitb91d3fe32660b1e04ac85f7ad4559443435e7edd (patch)
treebaed85fa20b1612b0cd4aa36b35ac48a5de768a5 /meta/recipes-devtools/dnf/dnf_2.6.3.bb
parent365b18dbef1e28db4688129cc3ad3db111b03285 (diff)
downloadpoky-b91d3fe32660b1e04ac85f7ad4559443435e7edd.tar.gz
dnf: update to 2.6.3
(From OE-Core rev: 685d7ec1114fa2ec4aa44f7e29d1e159f7899d4d) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/dnf/dnf_2.6.3.bb')
-rw-r--r--meta/recipes-devtools/dnf/dnf_2.6.3.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-devtools/dnf/dnf_2.6.3.bb b/meta/recipes-devtools/dnf/dnf_2.6.3.bb
new file mode 100644
index 0000000000..ade55ea0a8
--- /dev/null
+++ b/meta/recipes-devtools/dnf/dnf_2.6.3.bb
@@ -0,0 +1,49 @@
1SUMMARY = "Package manager forked from Yum, using libsolv as a dependency resolver"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
4 file://PACKAGE-LICENSING;md5=bfc29916e11321be06924c4fb096fdcc \
5 "
6
7SRC_URI = "git://github.com/rpm-software-management/dnf.git \
8 file://0029-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
9 file://0030-Run-python-scripts-using-env.patch \
10 file://0001-Do-not-prepend-installroot-to-logdir.patch \
11 file://0001-Do-not-hardcode-etc-and-systemd-unit-directories.patch \
12 file://0001-Corretly-install-tmpfiles.d-configuration.patch \
13 "
14
15SRCREV = "be2585183ec4485ee4d5e121f242d8669296f065"
16UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
17
18S = "${WORKDIR}/git"
19
20inherit cmake gettext bash-completion distutils3-base systemd
21
22DEPENDS += "libdnf librepo libcomps python3-iniparse"
23
24# manpages generation requires http://www.sphinx-doc.org/
25EXTRA_OECMAKE = " -DWITH_MAN=0 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
26
27BBCLASSEXTEND = "native nativesdk"
28RDEPENDS_${PN}_class-target += "python3-core python3-codecs python3-netclient python3-email python3-threading python3-distutils librepo python3-shell python3-subprocess libcomps libdnf python3-sqlite3 python3-compression python3-rpm python3-iniparse python3-json python3-importlib python3-curses python3-argparse python3-misc python3-gpg"
29
30# Create a symlink called 'dnf' as 'make install' does not do it, but
31# .spec file in dnf source tree does (and then Fedora and dnf documentation
32# says that dnf binary is plain 'dnf').
33do_install_append() {
34 lnr ${D}/${bindir}/dnf-3 ${D}/${bindir}/dnf
35 lnr ${D}/${bindir}/dnf-automatic-3 ${D}/${bindir}/dnf-automatic
36}
37
38# Direct dnf-native to read rpm configuration from our sysroot, not the one it was compiled in
39do_install_append_class-native() {
40 create_wrapper ${D}/${bindir}/dnf \
41 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
42 RPM_NO_CHROOT_FOR_SCRIPTS=1
43}
44
45SYSTEMD_SERVICE_${PN} = "dnf-makecache.service dnf-makecache.timer \
46 dnf-automatic-download.service dnf-automatic-download.timer \
47 dnf-automatic-install.service dnf-automatic-install.timer \
48 dnf-automatic-notifyonly.service dnf-automatic-notifyonly.timer \
49"