summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/distcc/distcc_2.18.3.bb
diff options
context:
space:
mode:
authorBogdan Marinescu <bogdan.a.marinescu@intel.com>2013-02-01 11:29:03 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-04 13:18:25 +0000
commit691a9908f54cfc213ee1fb3ffa690b2f30fb981d (patch)
tree32f6254992f8737789bfac760ca57aac1d6cb668 /meta/recipes-devtools/distcc/distcc_2.18.3.bb
parent57bbb7d6f4058ac41f37406046e684dfd2bd8ae0 (diff)
downloadpoky-691a9908f54cfc213ee1fb3ffa690b2f30fb981d.tar.gz
distcc: updated to version 3.1
Added two new flags to the configure script: --disable-Werror: don't treat all warnings all errors (which breaks compilation). PYTHON=/dev/null: this prevents distcc from detecting the host Python and trying to build its include server using the host Python. This disables the include server completely. If the include server is needed, that should be the object of another patch (and would introduce a dependency on python for distcc). The 'distcc-avahi' and 'makefile-param-order' patches are not needed anymore, as they were merged upstream. (From OE-Core rev: 3f33a6ecd9f1703381e175d688bdfce291ffdc8a) Signed-off-by: Bogdan Marinescu <bogdan.a.marinescu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/distcc/distcc_2.18.3.bb')
-rw-r--r--meta/recipes-devtools/distcc/distcc_2.18.3.bb65
1 files changed, 0 insertions, 65 deletions
diff --git a/meta/recipes-devtools/distcc/distcc_2.18.3.bb b/meta/recipes-devtools/distcc/distcc_2.18.3.bb
deleted file mode 100644
index bd2af4a1b5..0000000000
--- a/meta/recipes-devtools/distcc/distcc_2.18.3.bb
+++ /dev/null
@@ -1,65 +0,0 @@
1SUMMARY = "A parallel build system"
2DESCRIPTION = "distcc is a parallel build system that distributes \
3compilation of C/C++/ObjC code across machines on a network."
4SECTION = "devel"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7PR = "r9"
8
9DEPENDS = "avahi"
10
11GTKCONFIG = "gtk"
12GTKCONFIG_libc-uclibc = ""
13
14PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'x11', '${GTKCONFIG}', '', d)}"
15PACKAGECONFIG[gtk] = "--with-gtk,--without-gtk --without-gnome,gtk+"
16
17RRECOMMENDS_${PN} = "avahi-daemon"
18
19# Upstream change this patch periodically so store locally
20# http://0pointer.de/public/distcc-avahi.patch
21SRC_URI = "http://distcc.googlecode.com/files/${BPN}-${PV}.tar.bz2 \
22 file://distcc-avahi.patch \
23 file://makefile-param-order.patch \
24 file://default \
25 file://distccmon-gnome.desktop \
26 file://distcc"
27
28SRC_URI[md5sum] = "0d6b80a1efc3a3d816c4f4175f63eaa2"
29SRC_URI[sha256sum] = "6500f1bc2a30b1f044ebed79c6ce15457d1712263e65f0db7d6046af262ba434"
30
31inherit autotools pkgconfig update-rc.d useradd
32
33USERADD_PACKAGES = "${PN}"
34USERADD_PARAM_${PN} = "--system \
35 --home /dev/null \
36 --no-create-home \
37 --gid nogroup \
38 distcc"
39
40INITSCRIPT_NAME = "distcc"
41
42do_install_append() {
43 install -d ${D}${sysconfdir}/init.d/
44 install -d ${D}${sysconfdir}/default
45 install -m 0755 ${WORKDIR}/distcc ${D}${sysconfdir}/init.d/
46 install -m 0755 ${WORKDIR}/default ${D}${sysconfdir}/default/distcc
47 ${DESKTOPINSTALL}
48}
49DESKTOPINSTALL = ""
50DESKTOPINSTALL_libc-glibc () {
51 install -d ${D}${datadir}/distcc/
52 install -m 0644 ${WORKDIR}/distccmon-gnome.desktop ${D}${datadir}/distcc/
53}
54PACKAGES += "distcc-distmon-gnome"
55
56FILES_${PN} = " ${sysconfdir} \
57 ${bindir}/distcc \
58 ${bindir}/distccd \
59 ${bindir}/distccmon-text"
60FILES_distcc-distmon-gnome = " ${bindir}/distccmon-gnome \
61 ${datadir}/distcc"
62
63pkg_postrm_${PN} () {
64 deluser distcc || true
65}