summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/debugedit/debugedit_5.0.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2023-03-23 16:11:15 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-27 15:44:02 +0100
commit4ffcbe98e82c73c543aa46105413de2586aa1cee (patch)
treef57162b00c9e866d491e6e8324f1a46fa89f7cfa /meta/recipes-devtools/debugedit/debugedit_5.0.bb
parenta94ca827c2066b22c746003f5144b89d28b13a1a (diff)
downloadpoky-4ffcbe98e82c73c543aa46105413de2586aa1cee.tar.gz
debugedit: add recipe
This recipe provides find-debuginfo which is used by rpm, more specifically rpmbuild. RPM upstream removed find-debuginfo and switched to use debugedit in the following commit. https://github.com/rpm-software-management/rpm/commit/04b0805a756cdd9466fb9dc717846f5bf15518cc Without debugedit, rpmbuild fails to generate debuginfo package when %debug_package is added to spec file. (From OE-Core rev: f7ada8b4d003473abce5b589cc38aec1e5e5f18a) Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/debugedit/debugedit_5.0.bb')
-rw-r--r--meta/recipes-devtools/debugedit/debugedit_5.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/debugedit/debugedit_5.0.bb b/meta/recipes-devtools/debugedit/debugedit_5.0.bb
new file mode 100644
index 0000000000..257238fa24
--- /dev/null
+++ b/meta/recipes-devtools/debugedit/debugedit_5.0.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Tools for creating debuginfo and source file distributions"
2DESCRIPTION = "debugedit provides programs and scripts for creating \
3debuginfo and source file distributions, collect build-ids and rewrite \
4source paths in DWARF data for debugging, tracing and profiling."
5HOMEPAGE = "https://sourceware.org/debugedit/"
6
7LICENSE = "GPL-2.0-only & GPL-3.0-only & LGPL-2.1-only"
8LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
9 file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
10 file://COPYING3;md5=d32239bcb673463ab874e80d47fae504"
11
12SRC_URI = "https://sourceware.org/ftp/debugedit/${PV}/debugedit-${PV}.tar.xz"
13
14SRC_URI:append:libc-musl = " \
15 file://0001-tools-Add-error.h-for-non-glibc-case.patch \
16 file://0002-sepdebugcrcfix.c-do-not-use-64bit-variants.patch \
17 file://0003-Makefile.am-do-not-update-manual.patch \
18 "
19
20SRC_URI[sha256sum] = "e9ecd7d350bebae1f178ce6776ca19a648b6fe8fa22f5b3044b38d7899aa553e"
21
22DEPENDS = "elfutils"
23
24inherit pkgconfig autotools
25
26RDEPENDS:${PN} += "bash elfutils-binutils"
27
28BBCLASSEXTEND = "native nativesdk"