summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2021-09-22 21:13:34 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-11 18:41:38 +0100
commit573b0ea55e0e082156d9ed1d03f7c9857aaf3ff0 (patch)
tree9aa3864709d10f462a523a4244eb7664118d511e /meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb
parent7563013456cff4958d316daaa4fc8675e83ac962 (diff)
downloadpoky-573b0ea55e0e082156d9ed1d03f7c9857aaf3ff0.tar.gz
createrepo-c: upgrade 0.17.4 -> 0.17.5
(From OE-Core rev: 9f10592a011a58e0d481b529cd6a337ab68152d6) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb')
-rw-r--r--meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb40
1 files changed, 0 insertions, 40 deletions
diff --git a/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb b/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb
deleted file mode 100644
index 500b508d72..0000000000
--- a/meta/recipes-devtools/createrepo-c/createrepo-c_0.17.4.bb
+++ /dev/null
@@ -1,40 +0,0 @@
1DESCRIPTION = "C implementation of createrepo."
2HOMEPAGE = "https://github.com/rpm-software-management/createrepo_c/wiki"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7SRC_URI = "git://github.com/rpm-software-management/createrepo_c \
8 file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
9 "
10
11SRCREV = "cb74969736bdea86465e85feeceb895ff7a42610"
12
13S = "${WORKDIR}/git"
14
15DEPENDS = "expat curl glib-2.0 libxml2 openssl bzip2 zlib file sqlite3 xz rpm"
16DEPENDS:append:class-native = " file-replacement-native"
17
18inherit cmake pkgconfig bash-completion distutils3-base
19
20EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3 -DWITH_ZCHUNK=OFF -DENABLE_DRPM=OFF -DWITH_LIBMODULEMD=OFF"
21
22BBCLASSEXTEND = "native nativesdk"
23
24# Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in
25do_install:append:class-native() {
26 create_wrapper ${D}/${bindir}/createrepo_c \
27 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
28 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc
29 create_wrapper ${D}/${bindir}/modifyrepo_c \
30 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc
31}
32
33do_install:append:class-nativesdk() {
34 create_wrapper ${D}/${bindir}/createrepo_c \
35 RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm \
36 MAGIC=${datadir}/misc/magic.mgc
37 create_wrapper ${D}/${bindir}/modifyrepo_c \
38 MAGIC=${datadir}/misc/magic.mgc
39 rm -rf ${D}/etc
40}