summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake-native_3.8.2.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2017-06-02 15:42:43 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-05 09:19:51 +0100
commite3372ac0b4b0d1e5d246837aa940f020b6c0cfbc (patch)
treebea77bc5d99294d2e0b288eff358eeb4d4c60da4 /meta/recipes-devtools/cmake/cmake-native_3.8.2.bb
parent374f3d6be2df7393dc6ac5d7ea34f12e2d2c4f03 (diff)
downloadpoky-e3372ac0b4b0d1e5d246837aa940f020b6c0cfbc.tar.gz
cmake: Upgrade to 3.8.2
There was a set of changes, those are: - CMake now requires librhash for build and as there is no other users in OE-Core we make it use its internal copy instead; - Copyright.txt checksum has change due new contrubutors and 2017 year additions; - Patch avoid-gcc-warnings-with-Wstrict-prototypes.patch was removed as it is not need anymore; - Patch 0001-KWIML-tests-Remove-format-security-from-flags.patch was removed as it is included in this release. (From OE-Core rev: cc75f693bde412edd0a1aa4fd4e92fb29b492b76) Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake-native_3.8.2.bb')
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_3.8.2.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_3.8.2.bb b/meta/recipes-devtools/cmake/cmake-native_3.8.2.bb
new file mode 100644
index 0000000000..e55e8b1cf6
--- /dev/null
+++ b/meta/recipes-devtools/cmake/cmake-native_3.8.2.bb
@@ -0,0 +1,38 @@
1require cmake.inc
2inherit native
3
4DEPENDS += "bzip2-replacement-native expat-native xz-native zlib-native curl-native"
5
6SRC_URI += "\
7 file://cmlibarchive-disable-ext2fs.patch \
8"
9
10B = "${WORKDIR}/build"
11do_configure[cleandirs] = "${B}"
12
13# Disable ccmake since we don't depend on ncurses
14CMAKE_EXTRACONF = "\
15 -DCMAKE_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \
16 -DBUILD_CursesDialog=0 \
17 -DCMAKE_USE_SYSTEM_LIBRARIES=1 \
18 -DCMAKE_USE_SYSTEM_LIBRARY_JSONCPP=0 \
19 -DCMAKE_USE_SYSTEM_LIBRARY_LIBARCHIVE=0 \
20 -DCMAKE_USE_SYSTEM_LIBRARY_LIBUV=0 \
21 -DCMAKE_USE_SYSTEM_LIBRARY_LIBRHASH=0 \
22 -DENABLE_ACL=0 -DHAVE_ACL_LIBACL_H=0 \
23 -DHAVE_SYS_ACL_H=0 \
24"
25
26do_configure () {
27 ${S}/configure --verbose --prefix=${prefix} -- ${CMAKE_EXTRACONF}
28}
29
30do_compile() {
31 oe_runmake
32}
33
34do_install() {
35 oe_runmake 'DESTDIR=${D}' install
36}
37
38do_compile[progress] = "percent"