summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/cmake/cmake-native_3.6.1.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-09-14 17:41:35 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-16 15:24:02 +0100
commit08dc55ce846ee198e69e36dd8b49d26610279c86 (patch)
tree6107286c95416f4c6733a12a15bd807534d39186 /meta/recipes-devtools/cmake/cmake-native_3.6.1.bb
parent84e0260e036a5b294a37069fe163cb395e6427f4 (diff)
downloadpoky-08dc55ce846ee198e69e36dd8b49d26610279c86.tar.gz
cmake: don't inherit autotools
cmake doesn't use autotools, the functions get replaced by either cmake.bbclass (target) or the recipe itself (native) leaving just lots of superfluous dependencies. (From OE-Core rev: b8700e9fd30317d0ad583febb4e6f385284bdd51) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/cmake/cmake-native_3.6.1.bb')
-rw-r--r--meta/recipes-devtools/cmake/cmake-native_3.6.1.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta/recipes-devtools/cmake/cmake-native_3.6.1.bb b/meta/recipes-devtools/cmake/cmake-native_3.6.1.bb
index 33930fbb9c..f3a485fc0e 100644
--- a/meta/recipes-devtools/cmake/cmake-native_3.6.1.bb
+++ b/meta/recipes-devtools/cmake/cmake-native_3.6.1.bb
@@ -8,6 +8,9 @@ SRC_URI += "\
8 file://cmlibarchive-disable-ext2fs.patch \ 8 file://cmlibarchive-disable-ext2fs.patch \
9" 9"
10 10
11B = "${WORKDIR}/build"
12do_configure[cleandirs] = "${B}"
13
11# Disable ccmake since we don't depend on ncurses 14# Disable ccmake since we don't depend on ncurses
12CMAKE_EXTRACONF = "\ 15CMAKE_EXTRACONF = "\
13 -DBUILD_CursesDialog=0 \ 16 -DBUILD_CursesDialog=0 \
@@ -15,4 +18,16 @@ CMAKE_EXTRACONF = "\
15 -DHAVE_SYS_ACL_H=0 \ 18 -DHAVE_SYS_ACL_H=0 \
16" 19"
17 20
21do_configure () {
22 ${S}/configure --prefix=${prefix} -- ${CMAKE_EXTRACONF}
23}
24
25do_compile() {
26 oe_runmake
27}
28
29do_install() {
30 oe_runmake 'DESTDIR=${D}' install
31}
32
18do_compile[progress] = "percent" 33do_compile[progress] = "percent"