summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ccache/ccache_4.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-12-28 21:04:33 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-31 11:53:26 +0000
commit2ccb91bc740878f030002fb1a373a708bd125645 (patch)
tree546277252536311fcbdad2eeddd9a95a7cc9e7d0 /meta/recipes-devtools/ccache/ccache_4.1.bb
parent1027f7a3c3632321f542140b5f13e9f51879b0c4 (diff)
downloadpoky-2ccb91bc740878f030002fb1a373a708bd125645.tar.gz
ccache: upgrade 3.7.11 -> 4.1
Convert recipe from autotools to cmake. zstd is a new hard dependency. License-Update: formatting (From OE-Core rev: e373ecf276265a938a3acd42d9c25ce78d5f5330) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/ccache/ccache_4.1.bb')
-rw-r--r--meta/recipes-devtools/ccache/ccache_4.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ccache/ccache_4.1.bb b/meta/recipes-devtools/ccache/ccache_4.1.bb
new file mode 100644
index 0000000000..5f7d93b485
--- /dev/null
+++ b/meta/recipes-devtools/ccache/ccache_4.1.bb
@@ -0,0 +1,24 @@
1SUMMARY = "a fast C/C++ compiler cache"
2DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \
3by caching the result of previous compilations and detecting when the \
4same compilation is being done again. Supported languages are C, C\+\+, \
5Objective-C and Objective-C++."
6HOMEPAGE = "http://ccache.samba.org"
7SECTION = "devel"
8
9LICENSE = "GPLv3+"
10LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=a66c581f855c1c408730fe5d171e3013"
11
12DEPENDS = "zstd"
13
14SRC_URI = "https://github.com/ccache/ccache/releases/download/v${PV}/${BP}.tar.gz"
15SRC_URI[sha256sum] = "cdeefb827b3eef3b42b5454858123881a4a90abbd46cc72cf8c20b3bd039deb7"
16
17UPSTREAM_CHECK_URI = "https://github.com/ccache/ccache/releases/"
18
19inherit cmake
20
21PATCHTOOL = "patch"
22
23BBCLASSEXTEND = "native"
24