summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.9.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-11-02 17:48:38 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-03 08:21:12 +0000
commit4e6ff213ba9306c0e6f3ec1c4db20fcf96eab875 (patch)
tree3872189434603f820611d0757e32c4656059c52f /meta/recipes-devtools/btrfs-tools/btrfs-tools_5.9.bb
parentc7ef37c86a58c032c5c558fd2441f491b6afd0e3 (diff)
downloadpoky-4e6ff213ba9306c0e6f3ec1c4db20fcf96eab875.tar.gz
btrfs-tools: upgrade 5.7 -> 5.9
(From OE-Core rev: 10a43505acc84b73d7bfcf0da0ddeef3c5a23a3c) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/btrfs-tools/btrfs-tools_5.9.bb')
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools_5.9.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.9.bb b/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.9.bb
new file mode 100644
index 0000000000..15a958e624
--- /dev/null
+++ b/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.9.bb
@@ -0,0 +1,52 @@
1SUMMARY = "Checksumming Copy on Write Filesystem utilities"
2DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \
3implementing advanced features while focusing on fault tolerance, repair and \
4easy administration. \
5This package contains utilities (mkfs, fsck, btrfsctl) used to work with \
6btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3."
7
8HOMEPAGE = "https://btrfs.wiki.kernel.org"
9
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067"
12SECTION = "base"
13DEPENDS = "util-linux attr e2fsprogs lzo acl"
14DEPENDS_append_class-target = " udev"
15RDEPENDS_${PN} = "libgcc"
16
17SRCREV = "2e1fa482300449042ff6612bb51027f3f5765270"
18SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
19 file://0001-Add-a-possibility-to-specify-where-python-modules-ar.patch \
20 "
21
22PACKAGECONFIG ??= "python"
23PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native"
24PACKAGECONFIG[python] = "--enable-python,--disable-python,python3-setuptools-native"
25PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd"
26
27inherit autotools-brokensep pkgconfig manpages
28inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'distutils3-base', '', d)}
29
30CLEANBROKEN = "1"
31
32EXTRA_OECONF_append_libc-musl = " --disable-backtrace "
33EXTRA_PYTHON_CFLAGS = "${DEBUG_PREFIX_MAP}"
34EXTRA_PYTHON_CFLAGS_class-native = ""
35EXTRA_PYTHON_LDFLAGS = "${LDFLAGS}"
36EXTRA_OEMAKE = "V=1 'EXTRA_PYTHON_CFLAGS=${EXTRA_PYTHON_CFLAGS}' 'EXTRA_PYTHON_LDFLAGS=${EXTRA_PYTHON_LDFLAGS}'"
37
38do_configure_prepend() {
39 # Upstream doesn't ship this and autoreconf won't install it as automake isn't used.
40 mkdir -p ${S}/config
41 cp -f $(automake --print-libdir)/install-sh ${S}/config/
42}
43
44S = "${WORKDIR}/git"
45
46do_install_append() {
47 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
48 oe_runmake 'DESTDIR=${D}' 'PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR}' install_python
49 fi
50}
51
52BBCLASSEXTEND = "native nativesdk"