summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.1.1.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-06-19 15:24:49 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-20 13:14:21 +0100
commitf850f85b82b2ba1f5da9050b0669a6c7b9d6230a (patch)
tree39272abddb6cfd7e25e696f675555d5f22bfc55a /meta/recipes-devtools/btrfs-tools/btrfs-tools_5.1.1.bb
parent0b67e202ade226025d03f6dfd8049525f194660f (diff)
downloadpoky-f850f85b82b2ba1f5da9050b0669a6c7b9d6230a.tar.gz
btrfs-tools: update to 5.1.1
Drop backported patch, and a patch where upstream took care of the issue. (From OE-Core rev: 35bd7de678223f48443bddbeed4f4640534805a4) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/btrfs-tools/btrfs-tools_5.1.1.bb')
-rw-r--r--meta/recipes-devtools/btrfs-tools/btrfs-tools_5.1.1.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.1.1.bb b/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.1.1.bb
new file mode 100644
index 0000000000..2cd99706b4
--- /dev/null
+++ b/meta/recipes-devtools/btrfs-tools/btrfs-tools_5.1.1.bb
@@ -0,0 +1,46 @@
1SUMMARY = "Checksumming Copy on Write Filesystem utilities"
2DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \
3implementing advanced features while focusing on fault tolerance, repair and \
4easy administration. \
5This package contains utilities (mkfs, fsck, btrfsctl) used to work with \
6btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3."
7
8HOMEPAGE = "https://btrfs.wiki.kernel.org"
9
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067"
12SECTION = "base"
13DEPENDS = "util-linux attr e2fsprogs lzo acl python3-setuptools-native"
14DEPENDS_append_class-target = " udev"
15RDEPENDS_${PN} = "libgcc"
16
17SRCREV = "781e36a784faa58a4f0515eef124af860d59e2c0"
18SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
19 file://0001-Add-a-possibility-to-specify-where-python-modules-ar.patch \
20 "
21
22inherit autotools-brokensep pkgconfig manpages distutils3-base
23
24CLEANBROKEN = "1"
25
26PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native"
27EXTRA_OECONF = " --disable-zstd"
28EXTRA_OECONF_append_libc-musl = " --disable-backtrace "
29EXTRA_PYTHON_CFLAGS = "${DEBUG_PREFIX_MAP}"
30EXTRA_PYTHON_CFLAGS_class-native = ""
31EXTRA_PYTHON_LDFLAGS = "${LDFLAGS}"
32EXTRA_OEMAKE = "V=1 'EXTRA_PYTHON_CFLAGS=${EXTRA_PYTHON_CFLAGS}' 'EXTRA_PYTHON_LDFLAGS=${EXTRA_PYTHON_LDFLAGS}'"
33
34do_configure_prepend() {
35 # Upstream doesn't ship this and autoreconf won't install it as automake isn't used.
36 mkdir -p ${S}/config
37 cp -f $(automake --print-libdir)/install-sh ${S}/config/
38}
39
40S = "${WORKDIR}/git"
41
42do_install_append() {
43 oe_runmake 'DESTDIR=${D}' 'PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR}' install_python
44}
45
46BBCLASSEXTEND = "native"