summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-28 23:28:15 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-02 15:44:10 +0100
commitbb6ddc3691ab04162ec5fd69a2d5e7876713fd15 (patch)
tree76e376b01253c3aace1a98a5021bcaad3c92e861 /meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb
parentfcc456ee4b8f619134abb4649db53c638074082c (diff)
downloadpoky-bb6ddc3691ab04162ec5fd69a2d5e7876713fd15.tar.gz
Convert to new override syntax
This is the result of automated script conversion: scripts/contrib/convert-overrides.py <oe-core directory> converting the metadata to use ":" as the override character instead of "_". (From OE-Core rev: 42344347be29f0997cc2f7636d9603b1fe1875ae) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb')
-rw-r--r--meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb30
1 files changed, 15 insertions, 15 deletions
diff --git a/meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb b/meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb
index f6a77b4606..b1d359ec38 100644
--- a/meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb
+++ b/meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb
@@ -101,14 +101,14 @@ SRCREV = "868a2afab9da34f32c007d773b77253c93104636"
101 101
102inherit systemd update-rc.d python3native update-alternatives 102inherit systemd update-rc.d python3native update-alternatives
103 103
104ALTERNATIVE_${PN} = "bootchartd" 104ALTERNATIVE:${PN} = "bootchartd"
105ALTERNATIVE_LINK_NAME[bootchartd] = "${base_sbindir}/bootchartd" 105ALTERNATIVE_LINK_NAME[bootchartd] = "${base_sbindir}/bootchartd"
106ALTERNATIVE_PRIORITY = "100" 106ALTERNATIVE_PRIORITY = "100"
107 107
108# The only reason to build bootchart2-native is for a native pybootchartgui. 108# The only reason to build bootchart2-native is for a native pybootchartgui.
109BBCLASSEXTEND = "native" 109BBCLASSEXTEND = "native"
110 110
111SYSTEMD_SERVICE_${PN} = "bootchart2.service bootchart2-done.service bootchart2-done.timer" 111SYSTEMD_SERVICE:${PN} = "bootchart2.service bootchart2-done.service bootchart2-done.timer"
112 112
113UPDATERCPN = "bootchartd-stop-initscript" 113UPDATERCPN = "bootchartd-stop-initscript"
114INITSCRIPT_NAME = "bootchartd_stop.sh" 114INITSCRIPT_NAME = "bootchartd_stop.sh"
@@ -116,7 +116,7 @@ INITSCRIPT_PARAMS = "start 99 2 3 4 5 ."
116 116
117EXTRA_OEMAKE = 'BASE_SBINDIR="${base_sbindir}"' 117EXTRA_OEMAKE = 'BASE_SBINDIR="${base_sbindir}"'
118 118
119do_compile_prepend () { 119do_compile:prepend () {
120 export PY_LIBDIR="${libdir}/${PYTHON_DIR}" 120 export PY_LIBDIR="${libdir}/${PYTHON_DIR}"
121 export BINDIR="${bindir}" 121 export BINDIR="${bindir}"
122 export LIBDIR="${base_libdir}" 122 export LIBDIR="${base_libdir}"
@@ -145,19 +145,19 @@ do_install () {
145} 145}
146 146
147PACKAGES =+ "pybootchartgui" 147PACKAGES =+ "pybootchartgui"
148FILES_pybootchartgui += "${PYTHON_SITEPACKAGES_DIR}/pybootchartgui ${bindir}/pybootchartgui" 148FILES:pybootchartgui += "${PYTHON_SITEPACKAGES_DIR}/pybootchartgui ${bindir}/pybootchartgui"
149RDEPENDS_pybootchartgui = "python3-pycairo python3-compression python3-image python3-shell python3-compression python3-codecs" 149RDEPENDS:pybootchartgui = "python3-pycairo python3-compression python3-image python3-shell python3-compression python3-codecs"
150RDEPENDS_${PN}_class-target += "${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'sysvinit-pidof', 'procps', d)}" 150RDEPENDS:${PN}:class-target += "${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'sysvinit-pidof', 'procps', d)}"
151RDEPENDS_${PN}_class-target += "lsb-release" 151RDEPENDS:${PN}:class-target += "lsb-release"
152DEPENDS_append_class-native = " python3-pycairo-native" 152DEPENDS:append:class-native = " python3-pycairo-native"
153 153
154PACKAGES =+ "bootchartd-stop-initscript" 154PACKAGES =+ "bootchartd-stop-initscript"
155FILES_bootchartd-stop-initscript += "${sysconfdir}/init.d ${sysconfdir}/rc*.d" 155FILES:bootchartd-stop-initscript += "${sysconfdir}/init.d ${sysconfdir}/rc*.d"
156RDEPENDS_bootchartd-stop-initscript = "${PN}" 156RDEPENDS:bootchartd-stop-initscript = "${PN}"
157 157
158FILES_${PN} += "${base_libdir}/bootchart/bootchart-collector" 158FILES:${PN} += "${base_libdir}/bootchart/bootchart-collector"
159FILES_${PN} += "${base_libdir}/bootchart/tmpfs" 159FILES:${PN} += "${base_libdir}/bootchart/tmpfs"
160FILES_${PN} += "${libdir}" 160FILES:${PN} += "${libdir}"
161FILES_${PN}-doc += "${datadir}/docs" 161FILES:${PN}-doc += "${datadir}/docs"
162 162
163RCONFLICTS_${PN} = "bootchart" 163RCONFLICTS:${PN} = "bootchart"