summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/bison/bison_3.6.4.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-06-26 09:18:25 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-28 08:36:00 +0100
commit38cc8cb946668053c1a0819915a4abc64352690c (patch)
tree7bf51e285e8d1cf87dfa780e17e379fd1148a114 /meta/recipes-devtools/bison/bison_3.6.4.bb
parenteeec1005e936ee5a799be566e395c639f3b79e45 (diff)
downloadpoky-38cc8cb946668053c1a0819915a4abc64352690c.tar.gz
bison: upgrade 3.6.3 -> 3.6.4
(From OE-Core rev: 588ed940b8d43091cf6466d858cafeaf1c5f048d) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/bison/bison_3.6.4.bb')
-rw-r--r--meta/recipes-devtools/bison/bison_3.6.4.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bison/bison_3.6.4.bb b/meta/recipes-devtools/bison/bison_3.6.4.bb
new file mode 100644
index 0000000000..0c877c3c58
--- /dev/null
+++ b/meta/recipes-devtools/bison/bison_3.6.4.bb
@@ -0,0 +1,44 @@
1SUMMARY = "GNU Project parser generator (yacc replacement)"
2DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
4grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5little trouble."
6HOMEPAGE = "http://www.gnu.org/software/bison/"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
9SECTION = "devel"
10DEPENDS = "bison-native flex-native"
11
12SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \
13 file://add-with-bisonlocaledir.patch \
14 file://0001-bison-fix-the-parallel-build.patch \
15 "
16SRC_URI[sha256sum] = "8b13473b31ca7fcf65e5e8a74224368ffd5df19275602a9c9567ba393f18577d"
17
18# No point in hardcoding path to m4, just use PATH
19EXTRA_OECONF += "M4=m4"
20
21# Reset any loadavg set via environment, it breaks parallel build
22# | ../bison-3.5.2/lib/uniwidth/width.c:21:10: fatal error: uniwidth.h: No such file or directory
23# | #include "uniwidth.h"
24# | ^~~~~~~~~~~~
25EXTRA_OEMAKE_append = " -l"
26
27inherit autotools gettext texinfo
28
29# The automatic m4 path detection gets confused, so force the right value
30acpaths = "-I ${S}/m4"
31
32do_compile_prepend() {
33 for i in mfcalc calc++ rpcalc; do mkdir -p ${B}/examples/$i; done
34}
35
36do_install_append_class-native() {
37 create_wrapper ${D}/${bindir}/bison \
38 BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
39}
40do_install_append_class-nativesdk() {
41 create_wrapper ${D}/${bindir}/bison \
42 BISON_PKGDATADIR=${datadir}/bison
43}
44BBCLASSEXTEND = "native nativesdk"