summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/bison/bison_3.5.3.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-03-14 09:07:06 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-03-21 22:39:01 +0000
commitfcdb6774e9a4a1f111df3a8c65a5afd9e7e5a130 (patch)
treed965d4a0a3890921f229b602f7dcad52309b526d /meta/recipes-devtools/bison/bison_3.5.3.bb
parentb6ec9e65cf86b1b21a0f474a851a812823fcddd1 (diff)
downloadpoky-fcdb6774e9a4a1f111df3a8c65a5afd9e7e5a130.tar.gz
bison: Update to 3.5.3
bugfix release [1] [1] https://lists.gnu.org/archive/html/bison-announce/2020-03/msg00000.html (From OE-Core rev: b073317d5ea71217443624e5dc3b55831bb56018) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/bison/bison_3.5.3.bb')
-rw-r--r--meta/recipes-devtools/bison/bison_3.5.3.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bison/bison_3.5.3.bb b/meta/recipes-devtools/bison/bison_3.5.3.bb
new file mode 100644
index 0000000000..09e4b18f9e
--- /dev/null
+++ b/meta/recipes-devtools/bison/bison_3.5.3.bb
@@ -0,0 +1,38 @@
1SUMMARY = "GNU Project parser generator (yacc replacement)"
2DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
4grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5little trouble."
6HOMEPAGE = "http://www.gnu.org/software/bison/"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
9SECTION = "devel"
10DEPENDS = "bison-native flex-native"
11
12SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \
13 file://dont-depend-on-help2man.patch.patch \
14 file://add-with-bisonlocaledir.patch \
15"
16SRC_URI[sha256sum] = "2bf85b5f88a5f2fa8069aed2a2dfc3a9f8d15a97e59c713e3906e5fdd982a7c4"
17
18# No point in hardcoding path to m4, just use PATH
19EXTRA_OECONF += "M4=m4"
20
21inherit autotools gettext texinfo
22
23# The automatic m4 path detection gets confused, so force the right value
24acpaths = "-I ${S}/m4"
25
26do_compile_prepend() {
27 for i in mfcalc calc++ rpcalc; do mkdir -p ${B}/examples/$i; done
28}
29
30do_install_append_class-native() {
31 create_wrapper ${D}/${bindir}/bison \
32 BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
33}
34do_install_append_class-nativesdk() {
35 create_wrapper ${D}/${bindir}/bison \
36 BISON_PKGDATADIR=${datadir}/bison
37}
38BBCLASSEXTEND = "native nativesdk"