summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/bison/bison_3.0.4.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-04-14 02:07:12 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-21 07:20:26 +0100
commit6787dbc5f391f7fd0b27965cf5985107561f16b0 (patch)
tree3ac84c14bc66212e0632db02f0b5fa5954cedb03 /meta/recipes-devtools/bison/bison_3.0.4.bb
parent2b49fba71f83de4d0645a7def2d9437a727b6346 (diff)
downloadpoky-6787dbc5f391f7fd0b27965cf5985107561f16b0.tar.gz
bison: 2.7.1 -> 3.0.4
* Based on Chong Lu's previous upgrade to 3.0.2 * Remove unneeded patches: dont-depend-on-help2man.patch and fix_cross_manpage_building.patch (From OE-Core rev: fbb26d8db8e71fd979edd2bafa7e0bab7632950c) Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/bison/bison_3.0.4.bb')
-rw-r--r--meta/recipes-devtools/bison/bison_3.0.4.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bison/bison_3.0.4.bb b/meta/recipes-devtools/bison/bison_3.0.4.bb
new file mode 100644
index 0000000000..506141041c
--- /dev/null
+++ b/meta/recipes-devtools/bison/bison_3.0.4.bb
@@ -0,0 +1,37 @@
1SUMMARY = "GNU Project parser generator (yacc replacement)"
2DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
4grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5little trouble."
6HOMEPAGE = "http://www.gnu.org/software/bison/"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
9SECTION = "devel"
10DEPENDS = "bison-native flex-native"
11
12SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \
13 file://m4.patch \
14 file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
15"
16
17# No point in hardcoding path to m4, just use PATH
18EXTRA_OECONF += "M4=m4"
19
20SRC_URI[md5sum] = "c342201de104cc9ce0a21e0ad10d4021"
21SRC_URI[sha256sum] = "a72428c7917bdf9fa93cb8181c971b6e22834125848cf1d03ce10b1bb0716fe1"
22
23LDFLAGS_prepend_libc-uclibc = " -lrt "
24DEPENDS_class-native = "gettext-minimal-native"
25
26inherit autotools gettext texinfo
27acpaths = "-I ${S}/m4"
28
29do_compile_prepend() {
30 for i in mfcalc calc++ rpcalc; do mkdir -p ${B}/examples/$i; done
31}
32
33do_install_append_class-native() {
34 create_wrapper ${D}/${bindir}/bison \
35 BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
36}
37BBCLASSEXTEND = "native nativesdk"