summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/bison/bison_2.7.1.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-devtools/bison/bison_2.7.1.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-devtools/bison/bison_2.7.1.bb')
-rw-r--r--meta/recipes-devtools/bison/bison_2.7.1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bison/bison_2.7.1.bb b/meta/recipes-devtools/bison/bison_2.7.1.bb
new file mode 100644
index 0000000000..1df750a255
--- /dev/null
+++ b/meta/recipes-devtools/bison/bison_2.7.1.bb
@@ -0,0 +1,38 @@
1SUMMARY = "GNU Project parser generator (yacc replacement)"
2DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
4grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5little trouble."
6HOMEPAGE = "http://www.gnu.org/software/bison/"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
9SECTION = "devel"
10DEPENDS = "bison-native flex-native"
11
12BASE_SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \
13 file://m4.patch \
14 file://dont-depend-on-help2man.patch \
15 "
16
17# No point in hardcoding path to m4, just use PATH
18EXTRA_OECONF += "M4=m4"
19
20SRC_URI = "${BASE_SRC_URI} \
21 file://fix_cross_manpage_building.patch \
22 "
23
24SRC_URI[md5sum] = "7be02eb973eccf388f1ae750fc09eed0"
25SRC_URI[sha256sum] = "b409adcbf245baadb68d2f66accf6fdca5e282cafec1b865f4b5e963ba8ea7fb"
26
27LDFLAGS_prepend_libc-uclibc = " -lrt "
28DEPENDS_class-native = "gettext-minimal-native"
29SRC_URI_class-native = "${BASE_SRC_URI}"
30
31inherit autotools gettext
32acpaths = "-I ${S}/m4"
33
34do_install_append_class-native() {
35 create_wrapper ${D}/${bindir}/bison \
36 BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
37}
38BBCLASSEXTEND = "native nativesdk"