summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/binutils/binutils_2.32.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-17 17:21:39 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-10 13:21:40 +0100
commit3abf1c375c6e943c90a4bb14f86b5ed1b8f4ff39 (patch)
treea74dfc065c7e603e49a18122fa485888f71dfefc /meta/recipes-devtools/binutils/binutils_2.32.bb
parent7b0a620d4a4e2c4631e13d3b32dd3f917e960e22 (diff)
downloadpoky-3abf1c375c6e943c90a4bb14f86b5ed1b8f4ff39.tar.gz
binutils: Fix relocation of ld.so.conf in nativesdk builds
We need binutils to look at our ld.so.conf file within the SDK to ensure we search the SDK's libdirs as well as those from the host system. There add a patch which passes in the directory to the code using a define, then add it to a section we relocate in a similar way to the way we relocate the gcc internal paths. This ensures that ld works correctly in our buildtools tarball. Standard sysroot relocation doesn't work since we're not in a sysroot, we want to use both the host system and SDK libs. (From OE-Core rev: f6c1089642934ad93056ef19a0888965486ee030) (From OE-Core rev: 09a2b16ac2bd1e3e415131e46315c851373aa7e0) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/binutils/binutils_2.32.bb')
-rw-r--r--meta/recipes-devtools/binutils/binutils_2.32.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/binutils/binutils_2.32.bb b/meta/recipes-devtools/binutils/binutils_2.32.bb
index 89315915c4..c2833b8447 100644
--- a/meta/recipes-devtools/binutils/binutils_2.32.bb
+++ b/meta/recipes-devtools/binutils/binutils_2.32.bb
@@ -51,5 +51,7 @@ do_install_class-native () {
51PACKAGE_BEFORE_PN += "libbfd" 51PACKAGE_BEFORE_PN += "libbfd"
52FILES_libbfd = "${libdir}/libbfd-*.so" 52FILES_libbfd = "${libdir}/libbfd-*.so"
53 53
54SRC_URI_append_class-nativesdk = "file://nativesdk-relocation.patch"
55
54BBCLASSEXTEND = "native nativesdk" 56BBCLASSEXTEND = "native nativesdk"
55 57