summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/automake/automake_1.15.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-01-12 15:57:44 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-23 11:36:26 +0000
commitd97787346347526d163d0de69222bff2e7b25408 (patch)
tree861f190045e264d686e9dc0f7e52c53fc3e7952b /meta/recipes-devtools/automake/automake_1.15.bb
parent0d93a58483eb4a3f8d47893ef730fc9466d61b86 (diff)
downloadpoky-d97787346347526d163d0de69222bff2e7b25408.tar.gz
automake: upgrade to 1.15
(From OE-Core rev: 455edf38e8af854de0cffffdebf258b354ff7e54) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/automake/automake_1.15.bb')
-rw-r--r--meta/recipes-devtools/automake/automake_1.15.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-devtools/automake/automake_1.15.bb b/meta/recipes-devtools/automake/automake_1.15.bb
new file mode 100644
index 0000000000..d5b6e9eba4
--- /dev/null
+++ b/meta/recipes-devtools/automake/automake_1.15.bb
@@ -0,0 +1,42 @@
1require automake.inc
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4DEPENDS_class-native = "autoconf-native"
5
6NAMEVER = "${@oe.utils.trim_version("${PV}", 2)}"
7
8RDEPENDS_${PN} += "\
9 autoconf \
10 perl \
11 perl-module-bytes \
12 perl-module-data-dumper \
13 perl-module-strict \
14 perl-module-text-parsewords \
15 perl-module-thread-queue \
16 perl-module-threads \
17 perl-module-vars "
18
19RDEPENDS_${PN}_class-native = "autoconf-native perl-native-runtime"
20
21SRC_URI += " file://python-libdir.patch \
22 file://py-compile-compile-only-optimized-byte-code.patch \
23 file://buildtest.patch"
24
25SRC_URI[md5sum] = "716946a105ca228ab545fc37a70df3a3"
26SRC_URI[sha256sum] = "7946e945a96e28152ba5a6beb0625ca715c6e32ac55f2e353ef54def0c8ed924"
27
28do_install_append () {
29 install -d ${D}${datadir}
30
31 # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
32 # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
33 for i in aclocal aclocal-${NAMEVER} automake automake-${NAMEVER}; do
34 if [ -f ${D}${bindir}/$i ]; then
35 sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/perl,' \
36 -e 's,exec .*/bin/perl \(.*\) exec .*/bin/perl \(.*\),exec ${USRBINPATH}/perl \1 exec ${USRBINPATH}/perl \2,' \
37 ${D}${bindir}/$i
38 fi
39 done
40}
41
42BBCLASSEXTEND = "native nativesdk"