summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/automake/automake_1.15.bb
diff options
context:
space:
mode:
authorSerhii Popovych <spopovyc@cisco.com>2017-03-31 11:46:58 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-04-01 23:28:20 +0100
commit4aa21211a3051b95ef9a67c62646e016114eac30 (patch)
tree83de7d3d28efca6c36e96d8dc87b4988f9332e3d /meta/recipes-devtools/automake/automake_1.15.bb
parente44946bff10e04cc52c3871a65830e83ff4a2c41 (diff)
downloadpoky-4aa21211a3051b95ef9a67c62646e016114eac30.tar.gz
automake: Adjust shebang lines to remove interpreter path hardcode
If build host perl (and other tools) is old and we use some kind of toolchain to provide recent perl/python/etc to the OE build we still locked to use build host perl due to hardcoded shebang lines in automake scripts. Behaviour was observed with Enterprise Linux 6 and devtoolset toolchain from SCL (Software Collections) used to provide recent version of perl (not provided with default buildtools-tarball). Pass /usr/bin/env perl in ac_cv_path_PERL configuration variables for class-native and class-nativesdk. Use patch to automake to replace -w option in shebang line with modern way to enable warnings on perl (i.e. "use warnings"). Also add nativesdk-autoconf to RDEPENDS to bring runtime dependencies inline with other targets. Note that ac_cv_path_PERL must be valid perl interpreter path since configure will check perl version and Flock implementation. It is not possible currently to use nativeperl from native sysroot because automake does not DEPENDS on perl-native (and doing so fails due to circular dependencies). Only possible solution is to overwrite shebangs with nativeperl somewhere at do_install() and update RDEPENDS for class-native. Or add perl symlinks to nativeperl in sysroot. For now it seems good to use perl found by /usr/bin/env from automake-native. Cc: XE-Linux <xe-linux-external@cisco.com> (From OE-Core rev: 3b7111b30dbd9a4cdd141b594164da18c15ae970) Signed-off-by: Serhii Popovych <spopovyc@cisco.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/automake/automake_1.15.bb')
-rw-r--r--meta/recipes-devtools/automake/automake_1.15.bb13
1 files changed, 10 insertions, 3 deletions
diff --git a/meta/recipes-devtools/automake/automake_1.15.bb b/meta/recipes-devtools/automake/automake_1.15.bb
index a3c72fd334..a6904c8a91 100644
--- a/meta/recipes-devtools/automake/automake_1.15.bb
+++ b/meta/recipes-devtools/automake/automake_1.15.bb
@@ -17,16 +17,23 @@ RDEPENDS_${PN} += "\
17 perl-module-vars " 17 perl-module-vars "
18 18
19RDEPENDS_${PN}_class-native = "autoconf-native hostperl-runtime-native" 19RDEPENDS_${PN}_class-native = "autoconf-native hostperl-runtime-native"
20RDEPENDS_${PN}_class-nativesdk = "nativesdk-autoconf"
20 21
21SRC_URI += " file://python-libdir.patch \ 22SRC_URI += "file://python-libdir.patch \
22 file://buildtest.patch \ 23 file://buildtest.patch \
23 file://performance.patch \ 24 file://performance.patch \
24 file://new_rt_path_for_test-driver.patch" 25 file://new_rt_path_for_test-driver.patch \
26 file://automake-replace-w-option-in-shebangs-with-modern-use-warnings.patch \
27 "
25 28
26SRC_URI[md5sum] = "716946a105ca228ab545fc37a70df3a3" 29SRC_URI[md5sum] = "716946a105ca228ab545fc37a70df3a3"
27SRC_URI[sha256sum] = "7946e945a96e28152ba5a6beb0625ca715c6e32ac55f2e353ef54def0c8ed924" 30SRC_URI[sha256sum] = "7946e945a96e28152ba5a6beb0625ca715c6e32ac55f2e353ef54def0c8ed924"
28 31
29CACHED_CONFIGUREVARS += "ac_cv_path_PERL=${USRBINPATH}/perl" 32PERL = "${USRBINPATH}/perl"
33PERL_class-native = "${USRBINPATH}/env perl"
34PERL_class-nativesdk = "${USRBINPATH}/env perl"
35
36CACHED_CONFIGUREVARS += "ac_cv_path_PERL='${PERL}'"
30 37
31do_install_append () { 38do_install_append () {
32 install -d ${D}${datadir} 39 install -d ${D}${datadir}